Mercedes-Benz Forum banner
1 - 4 of 4 Posts

W220 Moderator
Joined
9,046 Posts
Discussion Starter · #1 ·
Hi Guys,

Did the 650 mile trip to Kent, car drove well on the way down there.

Once we arrived at our rental cottage, and got our second wind, a short trip into town to get some shopping...............

On the way back a loud slap, steering went tight and battery light came on.................bugger, it's thrown the belt !!
She started to warm up very quickly, and not wishing to get it too hot I pulled in to Meopham Station car park, and phoned the RAC.

A quick roadside look see revealed it hadn't just thrown the belt :(
There is a plastic idler pulley which bolts onto the water pump, and all that was left of it was the inner bearing race and the bolt :(

I got my 3 passengers and the shopping in a taxi and waited for RAC.
They sent a recovery truck straight away didn't even want to look at it LOL, so I got the truck to take me and the car to my old gearbox firm where I could work on it in the dry, with a ramp and proper tools, arrived there around 3:30 pm

Once at the workshop, I stripped off the plastic cover from under the inner wing and removed the belt completely, which was still in one piece, and assessed the situation. There is another plastic pulley on the tensioner, which comes as a complete unit, so a quick phone call to Euro Car Parts, yeah they had the idler pulley, tensioner and belt and would deliver it within the hour.
All the ancilliarys were turning freely with no play in their bearings, so I got the bolt and bearing race off the water pump, and the tensioner unit off, just as the parts arrived, then proceeded to reassemble it all.
I found it was easier to do the job by removing the crankshaft pulley, as it's very tight up there between the front of the engine and the O/S inner wing, a bit like I'd imagine doing Gaenecology in the dark LOL.

By 6pm it was all done and I drove back to our accommodation.

Can't really blame the car for this one, I was pushed for time to get all the other jobs done before leaving on our trip.
I prioritised getting the essential mechanical jobs done, first, and as the belt looked fairly recent I left it alone...............
There was a slight chirp for 10 - 20 seconds when starting the engine from cold, and I had wrongly assumed this was just a noisy belt !!
In fact it must have been the bearing in the idler pulley, because the noise is not there any more ;)

Car then drove fine for a couple of days, until on the Saturday night the headlights failed, just leaving me with sidelights, headlights flashing on and off if you wiggled the dipswitch stalk................Dipswitch gone !!

I was visiting a breakers while down south to collect the double front seat I had bought, so I got a switch while I was there...............As luck would have it the switch I got was almost new, 拢15 LOL.
So back to the workshop on Monday and fitted this, before travelling back home last Friday night.

Hopefully the lengthy trip has found all the hidden gremlins ;)

All I'm left to do now I'm back home is to fit the double front passenger seat, sort out the Electric Windows, Mirrors and Central Locking and then the old girl will be perfect..............Just how I like my vehicles to be ;)

Also worthy of a note, I'm not the easiest driver on a throttle pedal, and surprisingly the car averaged 40 - 45 mpg throughout the 1800 odd miles round trip.

All in all, despite the headaches I am very pleased with the car ;)

Cheers Dave.
 

W220 Moderator
Joined
9,046 Posts
Discussion Starter · #4 ·
LOL thanks fellas,

Last 3 weeks was more of an epic when you consider the hassle I had not getting the original V Class I was going to purchase, then going to Coventry at the eleventh hour to buy this one.

Then all the hassle with it cutting out on the way home due to the clogged up swirl pot, ordering all the service parts plus 2 new driveshafts, rollbar links and bushes, getting a punctured rear tyre fixed and finishing all the major works, full service including all brakes, plus a temporary repair to the driver side electric window using a Land Rover window switch !!

I finished that little lot at 5pm on the Wednesday 5th, loaded the car up, grabbed a few hours kip then headed south at 10pm Wednesday night :D

When we got back we found half the tiles missing off the roof of the newly built log cabin that the outlaws now live in, plus our satellite dish hanging off our house roof by the cables :eek:

Satellite fixed Saturday, I've re welded and reinforced the brackets so it'll pull the chimney down before it lets go again :D

Had to do that in the rain and wind, as we can't get terrestrial telly where we live and 2 nights of watching old DVDs drove us nuts :D

Just waiting for a break in the weather to temporarily felt the roof on the log cabin, and I'll replace the tiles next spring !!

Then hopefully I can get some paying work done before the end of the week, so I got some spends for Crimble LOL

Cheers for now,

Dave
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top