Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
95 E320
Joined
·
242 Posts
Discussion Starter #1
last night the car was surging, when the car would start to shift it would rev up really high then shift...

lst night my friend drove it about 30-50 miles w/ no problem, no the car wont shift and when u put the car in gear, there is no noise, but when you begin to press the gas nothing happens until about 2000 RPM's, then it will drive but very slowly, in both reverse and drive.

also i checked the tranny fluid, and didnt see any fluid, but couldnt really tell...

88' 300SEL

thank you
 

·
Registered
1991 300 SE
Joined
·
18,534 Posts
Before you can go further we must determine if you have enough ATF in the tranny. With the engine cold, pull the dipstick and see how much fluid there is. Normally one would check hot but since you can’t move your car we’ll do it this way. If there is little or no fluid on the dipstick cold then you may only be low on ATF.
 

·
Registered
2006 500SE, 1972 280SE
Joined
·
345 Posts
does it go into reverse? if so, then perhaps it is your B2 Piston, a common part to fail. This is a cheap fix and can be easily checked to see if the piston has failed. Mercedes mechanics will know where to check.
 

·
Registered
Depends on the day!
Joined
·
13,337 Posts
Sounds like you're just about out of fluid. A customers wife of mine did just what you did and. Do NOT drive the car. You'll burn the plates up. There is a leak and you need to find it as well as get the level correct.

Jonathan
 

·
Registered
95 E320
Joined
·
242 Posts
Discussion Starter #5
ok, sry for the late reply,

i checked the tranny fluid and there "appeared" to be none, both hot, and cold, so i put some in (about 2 bottles) and started it up and tried to drive, it worked fine, but the shifting was still a little off and some harsh shift...

then a wire right behind the front bumber began leaking lots, and lots, of what appeared to be tranny fluid, then we opened the hood and had realized that fluid had litteraly exploded all over the place and the entire engine bay was filled with it....

were goning to tow it tomorrow and have it checked out, but im thinking were going to just sell it and get a new car, as i only need one for about 3 months b4 school
 

·
Registered
Depends on the day!
Joined
·
13,337 Posts
ugh...[xx(]
 

·
Registered
1991 300 SE
Joined
·
18,534 Posts
Sounds like the transmission lines to the rad broke, same thing happened to me but with no explosion. Hopefully when the lines are replaced and the ATF is at normal level again, the transmission will work fine.
 
1 - 7 of 7 Posts
Top