Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
--------------------------------------------------------------------------------

Dear experts,

I have a problem with my Mercedes E270 cdi Avantgarde Saloon. Automatic 35,000 mileage. The car does not move when I put it into gear. Please help me in this dilemma and expalin to me how the situation arose.

My car suddenly last week stopped in the middle of the road and did not move when I put the gear in Drive or Reverse. All of a sudden! Then when I came out of the car the engine oil was leaking from underneath the car. The red one which costs about £10 per litre! Anyway I asked a mechanic and he said you need to replace the gasket, filter, plugs and fill up the oil again with 8 litres. I did all this and it cost me £250 with parts and labour. (I live in London) When I drove the car from the garage to my home, it drove for 0.25 of a mile and then stopped all of a sudden! So, I called the mechanic and he plugged in his leads with a laptop which has the Mercedes software for checking faults and it said the car was fine and working, no problem. But the car is not moving!!!

The Mercedes Mechanic does not know whats wrong. He said that the engine oil is replaced and the filter and plug and gasket are all replaced so it should be ok. Can the spillage have caused something else to happen and why has the engine oil spilled at only 35,000 mileage?

Also, the most mystifying thing is that when the car has not been driven for 2-3 hours and is cool, it will drive and then when it warms up and is driven for 0.25 miles it does'nt move all of a sudden.

It's mystifying because the mileage on the car is only 35,000 and is brand new. The engine and everthing else is working fine.

Finally, I must also mention that when he plugged in the laptop Mercedes software and put the car in manual gears 1,2,3,4 the software on the laptop was not recognizing the moving of different gears. Very weird yet the software says the car is fine.

Do I have a gearbox problem?
Has the car got a serious fault and what else could it be? I think it is the transmisson or a sensor in the gearbox. But no body knows. Even the so called experts. Maybe someones experienced a similar problem and can put me in the right direction.

Im sorry for the burden, I hope you can help.
 

·
Registered
W210.265/2001, W220/S500/2000, Porsche 997 C2S/2006, GMC K1500/1992
Joined
·
2,157 Posts
Wrong forum. This section deal with Personal electronic item in the MB only. Go to W210. You must complete your personal profile so member can help you with the info.
 
1 - 2 of 2 Posts
Top