Mercedes-Benz Forum banner

1 - 20 of 37 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
We've discussed these blades when I first bought them. I bought 2 424A Bosch Icon blades at Advance Auto on a buy one, get one free rebate, $42.28 without tax and expecting a check for half that. Advance Auto has changed rebate companies, they say there will be a 3 week delay until they get all the records straight. Not a good day to buy lottery tickets.

I've had the blade on for a little over two weeks now. Initially, I thought it made the arm sit too high, and I didn't like the not very 'crisp' sweep at the top of the stroke. It wiped very nicely on the 'over' stroke, not real good on the return stroke.
Bear in mind I am a fanatic about wiper blades, and hate any little streak in a wiper. In fairness, I called Bosch before I bought and they will not recommend the Icons for the W210. The guy said all sorts of glowing things about them, 'hinted' that the 24" would work, but officially won't recommend.

Last night we had a snowstorm in the Chicago area. Some reports had people traveling 45 minutes to go 2 miles, normal ½ hour trip was 4½ hours from downtown to the western suburbs. About 5 or 6 inches of snow.
The Icons were terrible. The stroke over was streaky but passable, the stroke back skipped the top 1/3 of the windshield. They iced up. Put on the front defroster and they started working better, but turned it off and they iced up again. The original blade iced up as well, but once defrosted it stayed defrosted while driving. I don't need to drive with that high heat, high blower defroster on all winter long. They are going back, I'm returning them as 'defective'. At less than half the price we can get better blades than these things.
I do not recommend Bosch Icon blades at all. :surrender:
 

·
Registered
Joined
·
31,633 Posts
Hey, JB, I rarely drive in snow and was on the fence about these, but your reports have confirmed that I'll just buy more stock refills at autohausaz.com.

Even with your rebate I can buy 3 refills for the price of one Icon.

Thanks for the feedback, I'm sure it will be useful to others as well.

Take care and enjoy the (soon-to-again-be-streak-free) ride,
Greg
 

·
Registered
Joined
·
98 Posts
Discussion Starter #3
I guess we have another storm coming, and supposed to be worse. This and single digit temperatures and it's still Fall! I want this weather in February when I'm in Hawaii so I don't have to deal with it!! "Adrift on an island..."
I will say this, the traction control thing really works! I had no problems at all when many did. Plus, I can still 'play' in the snow doing donuts and controlled slides and 180º's! I like it!
 

·
Registered
Joined
·
31,633 Posts
I guess we have another storm coming, and supposed to be worse. This and single digit temperatures and it's still Fall! I want this weather in February when I'm in Hawaii so I don't have to deal with it!! "Adrift on an island..."
I will say this, the traction control thing really works! I had no problems at all when many did. Plus, I can still 'play' in the snow doing donuts and controlled slides and 180º's! I like it!
I just realized I crested 8,000 posts...

For the non-noobs, they know where I am (SF Bay area) and that the listed location is a metaphysical reference to the distance between myself and some members and many mods/admins. It's all a bunch of history, I keep it that way to remind myself as much as anything else.

Take care and enjoy the controlled-drifting ride,
Greg
 

·
Premium Member
Joined
·
4,167 Posts
I had the same problem with the bosh icon blades in Nov going over the rocky mountains. Even with the defroster on high I could NOT keep the windshield clean with the icon blades, they kept icing up. In the past I've had no problems in any weather with the factory blades. By the way the icon blades are great on my Silverado pickup in the winter, which is why I decided to try them on the E-420.
 

·
Registered
Joined
·
1,332 Posts
JoeyB,

I was out in that same storm yesterday with my brand spanking new OEM Mercedes blades. There was a patch of ice that the blade would not clear high on the passengers side about the size of a dollar bill. I'm not a fan of the single blade design in the winter.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #8
Gregs, I just siezed the moment to 'plug' my vacation in Hawaii! I had planned to move there two years ago, but that's on hold for some family issues. I want out of the cold and on the island!!

echaocn, I agree. IMO, the Bosch Edge or Trico blades work best, past experience.

e-420, I appreciate the backup that I'm not nuts!! I had heard great things about the Icons, and Trico's beam blades, that's why I bought `em. The 'beam' style blades just might not work on a W210 for some reason.

Figuero, Wasn't last night fun?? Lol! You did better than I did. I had that patch all across the top, but it did clear for me with the defroster the 1st time I used it. It was too warm inside the car so I turned it off, and it froze up again and then would not clear. My last car was a Benz with one blade, had it 14½ years and no problems like this at all.
 

·
Registered
Joined
·
355 Posts
that's funny that you posted the review of the icons. i was actually gonna write a post about how i finally used my rain sensing wipers today for the first time (had the car since april, it literally does not rain in los angeles). i was very impressed. i found that they adjusted so well, that i forgot that they were on. usually i am turning them on and off at red lights etc....they really work.

i was also going to say in the post that i really like the icon blade too! but like i said this is the first time i've used them for rain...!
 

·
Registered
Joined
·
43 Posts
JoeyB, I got stuck driving home in that storm yesterday as well. I was very happy with my icon wiper through the summer...but what a disappointment in the snow. Every couple of minutes I had to reach out the window and snap the wiper against the windshield to knock off the ice. Absolutely the worst wiper for icy conditions.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #11
meooem1, Sure, rub it in! It's probably 70º everyday too! I really like the rain sensing intermittent feature too. I used to do the same as you, but this is really neat!


winerocks, Sounds like you had better luck with them in the rain than I did. I'm going to try the Trico Teflon blades. They say the ice won't stick, and guarantee one year smooth wiping. (Geez, that sounds gross)
 

·
Registered
Joined
·
201 Posts
Thanks

I too was considering the Bosch blades. Ohio has been cold and somewhat snowy as well. Global warming?? I wish...
 

·
Registered
Joined
·
3,461 Posts
Maybe I should just keep quiet and wait until you've had your accident due to bad visibility and then post "I've told you so". :mad::mad:

Or I should I just rant and rave at you and tell you to actually READ what is posted here? :confused:

I've posted this http://www.benzworld.org/forums/w210-e-class/1404029-how-replace-wiper-insert.html (see #8) three weeks ago about why Bosch Icon wipers WILL NOT WORK on the W210. Please read it, go out to your car, look at the wiper and then use your brain to work out what I've posted.

I've also answered it in this thread http://www.benzworld.org/forums/w210-e-class/1410812-recommended-oil-air-filters-2.html (see #18) specifically for Joey. :mad:

Any salesman that tells you that it should work on the W210 should be sued for endangering lives! There is a very logical reason why Bosch DOES NOT MAKE AN ICON WIPER FOR THE W210 :surrender:
 

·
Registered
Joined
·
3,461 Posts
You don't need the full wiper. My W201 (190E) with single wiper went for 15 years with the original wiper and just new inserts. Just get an insert from AutohausAZ or from the dealer. Kragen and other shops normally don't sell an insert long enough for the W210, but sometimes you can get lucky and they may stock one.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #16
That's nice, but if you read those of us who had problems, none were related to the wing or at speed.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #17
so what's the final verdict? do i go to dealership to get a new one? or walmart, pepboy?
I took the Icons back to Advance Auto Parts and exchanged them. They suggested the Trico 'Beam' style, the same style as the Icons. The Trico Beam blade also has the 'taller' center attachment point. In my opinion, this is where the problem with these blades lie. The design makes for more down pressure. They make the arm sit too high on the W210, and I'd guess that the Benz engineers over-engineered that spring as well as everything else.
So, I exchanged the Icons for the Trico Teflon blade, 15-240. As stated before, I had very good results with my last Benz using Trico Exact Fit and Bosch Micro Edge. The Teflons are supposed to have a heavier frame and no ice or snow stick, no chatter, and are guaranteed for a year. I haven't used them in the heavy stuff like the other day, but in light snow/sleet they work great. Clean and crisp sweep and wipe, and no noise.
 

·
Registered
Joined
·
3,461 Posts
That's nice, but if you read those of us who had problems, none were related to the wing or at speed.
Simple physics - wing = reduced downforce = water build-up on blade/windscreen = ice forming at low temperatures. The wing upsets down force even at low speed.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #19
Simple physics - wing = reduced downforce = water build-up on blade/windscreen = ice forming at low temperatures. The wing upsets down force even at low speed.
I understand what you are saying, and don't disagree. But the experiences posted in this thread are about being in a snow storm sitting still or crawling at traffic jam speeds. Bottom line, my experience, and that related by several others here says they don't work.
 

·
Registered
Joined
·
1,951 Posts
I too just replaced my ICON with the Excel+ blade... however... now this blade is still missing one inch on the outside edges... not sure why???

The ICON became way too streaky and the "spoiler" on it just placed a lot of mist/rain at the very bottom of the windshield when the wiper was parked... so if you were in intermittent mode, that portion would get really blurry real quick... a no go for me since thats where I see out of mostly.

The Excel+ wipes better... but the missing edge is bothering me quite a bit.
 
1 - 20 of 37 Posts
Top