Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Current: 82 380SL, 83 300D, 90 300E; Former 72 280SE, 85 380SL, 89 300E, 91 420SEL, and more!
Joined
·
43 Posts
Discussion Starter #1
Hello again fellow 123 lovers. I was about to put my rebuilt turbo in when I realized it may be a good time to remove my battery tray and clean up that area.

And I found this 2 lead wire connection, broken - 1 end is on, the other is broken... there is a lead I can find and can solder back some good wire and clean it up, but before I do - anyone know what its for?

Currently the only things that dont work on this car I am aware of is the vacum locks (need to diagnose), the tach, and the clock. Oh and my interior lights are all out, again none of that have a troubleshot yet, focused on the engine atm.

I don't think its related to any of those, maybe? Attaching a closeup and perspective. This is an 83 300 US Turbo Diesel, all stock even the radio (which does work).
2627411
2627412
 

·
Registered
1980 280CE; 1982 300CD
Joined
·
1,351 Posts
Looks like the plug for your right front wheel brake wear sensor.
There should be a wire in that area that goes through the fender to the brake caliper. If it grounds out as the pad is worn, a light on your dash will illuminate.
FB
 

·
Registered
1982 300D Turbodiesel (US Spec)
Joined
·
182 Posts
I just fixed this thing in my car! The wire broke or was cut by someone and since I didn’t have nothing better to do, I removed the 2 sections and soldered the wires. They are somewhat brittle and the filaments very thin, but is fixable if you have the patience.
 
1 - 4 of 4 Posts
Top