Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
1999 E430; 2005 ML500
Joined
·
1,692 Posts
that looks like the complete dash unit. what doesn't work on yours, just the parking heater?
 

·
Registered
2007 ML320 CDI Sport
Joined
·
42 Posts
Discussion Starter #3
Yeah had a code read in the summer that said something about the heater booster, i thought maybe this was it.

It's definitely not boosting the heat on a cold start, read that anything below 8oc should kick it in, well Ive had as low as -5 some mornings this past month and nothing, barely warm by the time ive driven 10 miles to work.
 

·
Registered
W219 320CDI -07 W220 320CDI -01 W210 270CDI -01 EX: W211 320CDI -04
Joined
·
1,221 Posts
Yeah had a code read in the summer that said something about the heater booster, i thought maybe this was it.

It's definitely not boosting the heat on a cold start, read that anything below 8oc should kick it in, well Ive had as low as -5 some mornings this past month and nothing, barely warm by the time ive driven 10 miles to work.
I believe your fault code was pointing to heater booster, which is located in coolant water line, and heats the coolant if ambient and engine temperatures are over/under certain values. You can control the heater on/off from button lcated in ash tray. Have you checked the fuse? Booster is just electric resistor warmer, and it's often broken... BTW, Is the normal running temperature of the engine around 80 Celsius?
 

·
Registered
2007 ML320 CDI Sport
Joined
·
42 Posts
Discussion Starter #5
Yeah i know there is a button to turn it off by the cig lighter, this does light up when pressed (to turn it off) but does nothing.

All fuses are good, went over them all with my meter.

I'd like to know exactly where this booster is and how easy it is to get to really?

Normal running temp is 80 yes but only after around 20 miles currently - 80 was achieved much faster in the summer.
 

·
Registered
W219 320CDI -07 W220 320CDI -01 W210 270CDI -01 EX: W211 320CDI -04
Joined
·
1,221 Posts
Yeah i know there is a button to turn it off by the cig lighter, this does light up when pressed (to turn it off) but does nothing.

All fuses are good, went over them all with my meter.

I'd like to know exactly where this booster is and how easy it is to get to really?

Normal running temp is 80 yes but only after around 20 miles currently - 80 was achieved much faster in the summer.
Part number MAY be A0001591104...
It's located close to engine block near starter, under intake manifold.

Found one in german ebay (you can see picture of heater):

Mercedes Benz Heizelement Heizeinsatz w210 w613 w628 bei eBay.de: Antrieb, Motor Getriebe (endet 07.12.10 14:46:16 MEZ)
 

·
Registered
2007 ML320 CDI Sport
Joined
·
42 Posts
Discussion Starter #7
Im quite new to this engine (only taken the cover off once!) could you point me to where I should be looking for the part buddy?



 

·
Registered
2007 ML320 CDI Sport
Joined
·
42 Posts
Discussion Starter #9 (Edited)
Ah nice one renault, was suspicious of that, so the black part must be the header tank for the heater yeah?

Will take it off one night this week and do some investigating!

Ps. think we have pretty much identical wagons, do you have one of the fuses missing for your aux heater? The fuse chart says 4, 7 & 17 (i think from memory) and I have no fuse in 17 - but there is only one contact present for it (the upper not the lower)- don't think it is meant to be there on mine. Would just be nice to know :)

Found a pic of mine;

 
1 - 10 of 10 Posts
Top