Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
82 300D, ISU Formula
Joined
·
225 Posts
Discussion Starter #1
Have an 82 300DT, and the other day my turn signals stopped blinking, all I get is both the front and rear singals stuck in the lit position whenever I use the signal. Is there some sort of turn signal relay that I could crack open to examine? Where would this relay be located in the car

Thanks
 

·
Registered
1982 300D Turbo
Joined
·
457 Posts
ya, its the hazard switch in the center consol. it runs through there.
 

·
Registered
82 300D, ISU Formula
Joined
·
225 Posts
Discussion Starter #3
But the funny thing is, is that the hazards still work fine. Maybe its another problem?
 

·
Registered
1982 300D Turbo
Joined
·
457 Posts
you check both your rear blinker bulbs? if they are out that would b a problem too
 

·
Registered
1980 240D
Joined
·
64 Posts
I had the same problem. After switching out all the bulbs, tearing apart the signal column switch, and replacing the hazard relay, I took it to someone who knows what they were doing. Right away he found multiple small shorts and one bad ground. the problem was resolved.

Taking it to him was cheaper than all the "little" parts I replaced while trying to track down the problem. :)

Erin
 

·
Registered
82 300D, ISU Formula
Joined
·
225 Posts
Discussion Starter #7
Found the problem, cleaned out the switch and the contacts, that fixed everything. Thanks
 

·
Registered
1982 300D Turbo
Joined
·
457 Posts
Glad to hear the good news [:)]
 
1 - 8 of 8 Posts
Top