Mercedes-Benz Forum banner

Tune-up

1266 Views 7 Replies 3 Participants Last post by  Ignatz
Hello!
I would like to know what points of the injection/ignition system should be adjusted in order to perform a complete tune-up to the car (just because I have bought the car a few days ago and want to have it adjusted). Thinks like spark plugs, distributor, etc. What are the really important things to check/clean/change in order to improve performance/economy? Is the idle adjustable?
My car is a MB190E 2.3 (8V) from 1992.
Thanks
1 - 8 of 8 Posts

· Registered
350SLC, 500SLC, 300TE, 190E2.3 Sportline
Joined
·
687 Posts
Not much to tune

There is not much to tune-up. Idle speed and ignition timing are controlled electronically. Basic mixture setting is adjustable (only with correct measuring equipment) and the precise mixture control is done electronically relative to the feedback from the oxygen sensor in the exhaust system. So long as everything (including plugs, HT wires, distributor rotor and cap) is in good working order and filters are clean, all should be fine. If anything is not right (eg. idle speed) then there must be a fault which should be diagnosed and corrected.
 

· Registered
Joined
·
96 Posts
Discussion Starter · #3 ·
Thanks,
By the way, I have seen that you have a 190E 2.3 like me. Could you tell me wha...


Thanks,
By the way, I have seen that you have a 190E 2.3 like me. Could you tell me what is the correct idle speed? Does it get somewhat higher (about 1000rpm) for a few seconds when starting from cold and then go lower to the normal speed? That's what mine does.

Best regards.
 

· Registered
350SLC, 500SLC, 300TE, 190E2.3 Sportline
Joined
·
687 Posts
Correct idle speed is about 750. My Aussie delivery has it shown on an emissions informati...

Correct idle speed is about 750. My Aussie delivery has it shown on an emissions information label in the engine bay. The fast idle at a cold start is perfectly normal.
 

· Registered
Joined
·
96 Posts
Discussion Starter · #5 ·
Thanks!
Is your idle perfectly regular or do you notice slight vibrations in the car? W...


Thanks!
Is your idle perfectly regular or do you notice slight vibrations in the car? What about the start-up? Does it fire inmediately and finely or a little bit roughly?
Mine also does a weird rattle at the front and it even "screams" when pressing the throotle suddenly, I think that the aux belt is not correctly tensioned or the tensioner is bad.

Sorry for so many questions, but I am in my way to get used to my new car and want to know the possible weak points to have ir revised.

Best regards
 

· Registered
350SLC, 500SLC, 300TE, 190E2.3 Sportline
Joined
·
687 Posts
Slight vibrations at idle are common and no cause for concern. Factors such as worn engine...

Slight vibrations at idle are common and no cause for concern. Factors such as worn engine mounts, injectors and ignition components can make matters worse. Ageing fuel and ignition components can also make for difficult or rough starts. Having said that, I have also known of low mileage examples in good condition that don't start perfectly. The rattle at start-up could be timing chain. Ticking at start-up is valve lifters. The scream is due to the belt slipping. Check the condition of the belt and tensioner. Tensioners are known to fail causing the belt to slip.
 

· Registered
Joined
·
96 Posts
Discussion Starter · #7 ·
Thanks. I will change spark plugs, perform a clean-up of the fuel system and revise the ...

Thanks. I will change spark plugs, perform a clean-up of the fuel system and revise the tensioner and aux belt. Let's see how it goes.

Your help is very appreciated.

Sergio
 

· Registered
1993 190e-2.3
Joined
·
765 Posts
Ive owned my 93 190e2.3 for 6 years now. Its maintained perfectly but ocasionaly the idle ...

Ive owned my 93 190e2.3 for 6 years now. Its maintained perfectly but ocasionaly the idle stumbles. When it does, I simply add Chevron Techron and it clears up. I know this sounds extreme but I add 35ml. of Techron to each tankfull and have'nt had a single glitch in over a year. I have about six old containers of Techron that I fill up, put in the trunk and when the wife fills up she adds one. 140,000 miles and runs like new.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top