Mercedes-Benz Forum banner

trunk lid not staying fully closed

1127 Views 4 Replies 3 Participants Last post by  barry putnam
Any ideas for a fix please:

When I close the trunk lid the vacum assist closes the trunk lid tight so that the lid is flush with the back fenders. Then about 10 seconds later, the vacum relaxes a little and the lid moves up a couple of centimeters, so now it is not even with the fenders. There is a little gap. I can push it down with my hand, but it won't stay down. Any idea where/how to fix this?

Thanks

Barry
1 - 5 of 5 Posts

· Registered
2014 B250e, 2007 SL550
Joined
·
40 Posts
Mine stays down untill I engage R and the refrence posts go up. In 5-7 seconds, I hear a c...

Mine stays down untill I engage R and the refrence posts go up. In 5-7 seconds, I hear a click and the trunk opens a litle. If I only drive forward, it does not open.
Vacuum leak, I am sure.
I still have to learn a litle more before diggin this one.
 

· Registered
92 500SEL to 01 E320T current 2014 lexus LS460
Joined
·
3,885 Posts
!40 trunk assist

I would suggest you try two things, check the (lower) latch for adjustment, mine has come loose before. Close the latch by hand, the one on the body not the lid. The catch should retract like it is pulling the lid down, check to see if it is coming back to its origional position after a few seconds.The sign of a bad pump is to not pull it in at all, maybe the (lid latch) is just binding, and after the vacum is released it has not latched.
 

· Registered
1995 MB S320V: 2006 kawasaki vulcan 900 lt
Joined
·
414 Posts
Discussion Starter · #4 ·
lid

I tried to follow your advice, re the lower catch on the body. My car seens to have the air assist in the trunk lid catch instead, it moves when I engage the lock unlock switch. Seems to be a litle tighter after manualy closing thow. Will persue it more after the holiday weekend.

Thanks

Barry
 

· Registered
1995 MB S320V: 2006 kawasaki vulcan 900 lt
Joined
·
414 Posts
Discussion Starter · #5 ·
Re: !40 trunk assist

I would suggest you try two things, check the (lower) latch for adjustment, mine has come loose before. Close the latch by hand, the one on the body not the lid. The catch should retract like it is pulling the lid down, check to see if it is coming back to its origional position after a few seconds.The sign of a bad pump is to not pull it in at all, maybe the (lid latch) is just binding, and after the vacum is released it has not latched.
[^]I checked the lower latch, and sure enough it was loose. Took off the plastic trim around the trunk body and tightened it with a torqx. Now it is nice and tight.

Thanks for the help

Barry
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top