Mercedes-Benz Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello everyone. I own a 1996 e320 and I have noticed that my brake lights are not illuminating when pressing the pedal. My tailights are on when headlights are on but does illuminate either. Heres what I have already done.

1. Checked all 3 fuse location
2. Changed the brake switch
3.Checked the bulbs
4. Check the brake switch harness for power(there is no power when care off and power when care is on) Should'nt the brakes have power when the car is off?


Any help will do. I am banging my head against the wall.:confused:
 

·
Registered
1999 E300 Turbodiesel
Joined
·
463 Posts
There is one small operation that you may want to revisit-----that is before you install the switch make sure that you pull the actuating pin ALL THE WAY OUT. Then fully depress brake pedal, insert switch and turn untill it catches.

Good luck
 

·
Registered
'99 E320 210 V6 Wagon rear wheel drive & '27 Bugatti kit car
Joined
·
13 Posts
Hello everyone. I own a 1996 e320 and I have noticed that my brake lights are not illuminating when pressing the pedal. My tailights are on when headlights are on but does illuminate either. Heres what I have already done.

1. Checked all 3 fuse location
2. Changed the brake switch
3.Checked the bulbs
4. Check the brake switch harness for power(there is no power when care off and power when care is on) Should'nt the brakes have power when the car is off?


Any help will do. I am banging my head against the wall.:confused:
My brake lights only work when the key is turned on also so I guess this is normal.
 
1 - 3 of 3 Posts
Top