Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
1999 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Joined
·
2,657 Posts
Discussion Starter #1
Regarding my 1999 E320:

My trip counter and odometer is very dim compared to the temperature and clock display. It's very hard to see in the daytime. More annoying than anything else.

It it the pixels or is there a backlight that is burnt out?
20200214_131333.jpg
 

·
Premium Member
1998 E320 base sedan @ 160kmiles
Joined
·
6,195 Posts
The middle bulb behind the odometer is gone. If you tap on the odometer area, several times it may come back briefly to confirm.
 

·
Registered
1999 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Joined
·
2,657 Posts
Discussion Starter #3
Thanks. I wasn't sure if there were bulbs behind the display or just the leds/pixels were going bad.
 

·
Registered
E320/E250 Bluetec Ford F350 6.7l
Joined
·
36,327 Posts
Get whole set of bulb that work all the time ready to replace.
I usually don't believe in such coincidences, but doing the ribbon on W210 cluster, after reinstallation about 4 bulbs were bad.
I figured out that heavily used bulbs don't take much and vibration associated with cluster removal was all it takes to have the small wire shaken.
 

·
Registered
1999 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Joined
·
2,657 Posts
Discussion Starter #5
Get whole set of bulb that work all the time ready to replace.
I usually don't believe in such coincidences, but doing the ribbon on W210 cluster, after reinstallation about 4 bulbs were bad.
I figured out that heavily used bulbs don't take much and vibration associated with cluster removal was all it takes to have the small wire shaken.
That's what I was thinking. I didn't want to pull the cluster to see if there were bulbs behind there, hence my original post.
 

·
Registered
1999 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Joined
·
2,657 Posts
Discussion Starter #6
Seems easy enough:

 

·
Registered
1996 SL500, 2000 E430
Joined
·
3,670 Posts
As mrboca said - on mine (2000) there were 2 bulbs behind the odometer area - it was a relief to see the bulb replacement fix it.

I got mine - color coded - make sure you keep the same colors - at autohausaz. Quite a savings.
 
1 - 7 of 7 Posts
Top