Mercedes-Benz Forum banner

1 - 18 of 18 Posts

·
Registered
2007 S550
Joined
·
19 Posts
Discussion Starter #1 (Edited)
Has this happened to anyone?
I have a 2007 S550.
Tonight on the way home from work, the car started with no problem but it seemed like the torque converted went south...lagging start with the car finally moving forward (hesitatingly) with the tach @ 3,000 rpm.

So I pull over and shut it down, restart and when I put it in gear I feel a lurch as the transmission engages. The Check Engine symbol is now lit and the car rolls out normally except that it won't shift into 2nd gear or any other forward gear for that matter. Its as though the transmission is stuck in some emergency-default mode.

Has anyone had a similar incident?

Thanks,

PSK
 

·
Registered
222.132 & 221.122 & 213.050 & 906.633
Joined
·
10,425 Posts
Sounds like the car went to limp-home-mode. How much does it have on the clock? Since the check engine light is on, it might not be tranny related. Have the codes read with star.
 

·
Registered
2007 S550
Joined
·
19 Posts
Discussion Starter #3
Valve Body

Thank you for your input.
I took it to the dealer. Turns out some valves were sticking in the transmission valve body assembly and the transmission's electronic brain was throwing the transmission into a default safety mode.
Warranties are wondwrful things.:D
 

·
Registered
1988 300 TE. 2001 ML 55AMG The Shop is Open!!!
Joined
·
328 Posts
Has this happened to anyone?
I have a 2007 S550.
Tonight on the way home from work, the car started with no problem but it seemed like the torque converted went south...lagging start with the car finally moving forward (hesitatingly) with the tach @ 3,000 rpm.

So I pull over and shut it down, restart and when I put it in gear I feel a lurch as the transmission engages. The Check Engine symbol is now lit and the car rolls out normally except that it won't shift into 2nd gear or any other forward gear for that matter. Its as though the transmission is stuck in some emergency-default mode.

Has anyone had a similar incident?

Thanks,

PSK
This boggles my mind... Why do people post and ask about problems on their car when it is still fresh and new and covered under the factory warranty??

If it is under warranty, I just take it in and tell them what is going on. Now I understand if the same concern keeps happening over and over and over, then It is time to seek other help.

But if is the first incident, let them handle it.

Just a statement...

Happy Benzing!!!
 

·
Registered
222.132 & 221.122 & 213.050 & 906.633
Joined
·
10,425 Posts
This boggles my mind... Why do people post and ask about problems on their car when it is still fresh and new and covered under the factory warranty??

If it is under warranty, I just take it in and tell them what is going on. Now I understand if the same concern keeps happening over and over and over, then It is time to seek other help.

But if is the first incident, let them handle it.

Just a statement...

Happy Benzing!!!
I have been wondering the same sometimes. I've understood one issue being the very long distance to a dealer, from some US locations and owners prefer to try a DIY fix if it was easy.

On the other hand, even if the car was covered by warranty, at the same age the car probably would not have warranty in Europe and the ROW, then it is very useful for us to learn about the issues that were fixed for free by the dealer. Unfortunately many of us would like to have you unemployed as far as possible. :)
 

·
Registered
2007 S550
Joined
·
19 Posts
Discussion Starter #6
This boggles my mind... Why do people post and ask about problems on their car when it is still fresh and new and covered under the factory warranty??

If it is under warranty, I just take it in and tell them what is going on. Now I understand if the same concern keeps happening over and over and over, then It is time to seek other help.

But if is the first incident, let them handle it.

Just a statement...

Happy Benzing!!!
~~~~~~~~~~~~~~~~~~


You may recall that the question in the thread's original post was;

"Has this happened to anyone?"

This question was followed by a brief description of the issue.

Re-reading the post I fail to see where I asked anyone for any mechanical expertise... I merely asked if this has happened to anyone else.

It happend that the dealer recognized that the car was still under warranty and they furnished a loaner whilst they replaced the transmission's electronic valve body.



For your elucidation:

The rationale for asking such a question even if the car is under warranty is this:

  • to determine if the issue is unique or common
  • to alert other people that may have similar vehicles of the issue
  • to advise other board members of the problem's diagnosis
  • to advise other board members of the problem's resolution
Aside from providing an outlet for many to show-off their rides and to varying degrees engage in "Mine is Bigger" flame fests, a principal benefit of a message board is to educate other owners of similar vehicles. Coming from owning 4 BMW sedans (three 7-Series & one 3-Series) one of the things the BMW Community has is its On-Line Communities which are densely populated and very diverse in scope. I had hoped to find the Mercedes Benz had a similarly extensive on-line community rather than the limited resource it has turned out to be.

No matter though, the S550 is the finest sedan I have ever driven.
 

·
Premium Member
'71 Pinto
Joined
·
4,419 Posts
Coming from owning 4 BMW sedans (three 7-Series & one 3-Series) one of the things the BMW Community has is its On-Line Communities which are densely populated and very diverse in scope. I had hoped to find the Mercedes Benz had a similarly extensive on-line community rather than the limited resource it has turned out to be.
You may also want to visit New S-Class (W221) - MBWorld.org Forums
 

·
Registered
1988 300 TE. 2001 ML 55AMG The Shop is Open!!!
Joined
·
328 Posts
..... Unfortunately many of us would like to have you unemployed as far as possible. :)
Yes I understand, and whatever field you work in, there is a DIY crowd that wishes the same for you... :)

Point well taken...

Happy Benzing!!!
 

·
Registered
2004 S430
Joined
·
15 Posts
I have an S 430 2004, and it happened two times with my car, first time at 35k miles and second 70k miles, lucky I have the extended warranty. But we have to be careful with the extended warranty ,even also from Mercedes Benz, dealer treated the warranty differently. On extended W if problem is intermittent and does not occur during inspection then dealers (some may not) will charge us for inspection. This problem may reset itself when engine turn off, so I drove the car directly to dealer and keep engine running until their mechanic checked the problem and witness it. At least in my case this is a defect design or something, what will happen when occur after warranty is over ?
 

·
Registered
W126, R107, W210 AMG, W221
Joined
·
342 Posts
It is quite essential to post a problem and solution to this forum. That may help others. No matter if the car is under warranty or not. And sometimes dealers don't know and you can suggest a solution and save time (week or so with a loaner..)
 

·
Registered
Joined
·
17 Posts
Thank you for your input.
I took it to the dealer. Turns out some valves were sticking in the transmission valve body assembly and the transmission's electronic brain was throwing the transmission into a default safety mode.
Warranties are wondwrful things.:D
I'm glad you posted this actually. My car (W140, different car entirely, I know) had/still sometimes has this issue where it seems to not leave 1st. I hadn't considered a stuck valve in the valvebody. Thanks!
 

·
Registered
2005 S500 4matic (gone), 2007 S550 4matic, AMG pkg, Pkg 2, 2010 C300 4matic sports pkg.
Joined
·
73 Posts
I have found that no matter what the postings were, I always learn something new about the W221. I personally want to know as much about my car as possible, Due to I my intent to keep the car after my warranty expired.
 

·
Registered
08 ml320 cdi,slk 230,01 boxster S,04 carrera911, 99 S320,67 GT350mustang,02G500L,96 s600 w140
Joined
·
1,667 Posts
after 5 to 7 years this thread will be very important to everyone here
 

·
Registered
Joined
·
8 Posts
Just happened to me tonight. Had to be towed to the dealer. Only had my car for 2 weeks (07 s550 4Matic) with 31k on the clock. Not a happy camper at this point....
 

·
Registered
Joined
·
1 Posts
Hi everybody,
could someone advise me some website to order 7 gtronic transmission for w221 2007, I cant find it Kazakhstan and Russia. I have to order it through dealers not even official ones and should wait for at least 2-3 months to get it delivered. Any advise on some real transmission shop in Europe?preferably in Germany
 

·
Registered
2008 s550 4 Matic AMG
Joined
·
1 Posts
Same thing happens to my transmission 2007 S550 4matic at 28000mi. and out of warranty :(. WTF how come its not a factory recall. Previous owned 2004 Audi A8L for 6 years and no problem.
 
1 - 18 of 18 Posts
Top