Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
2002 ML320
Joined
·
1,951 Posts
Discussion Starter #1
Hey all... I have recently purchased a 2002 ML320 and am loving it!!

Question here is... the transmission in the ML is a lot more smooth than in my C230... you can barely tell it is shifting... but in the C230 it is very abrupt at times... especially the 1-2 shift... are the transmissions in the C230's programmed differently due to the Kompressor? Or... do I have something that needs to be investigated?

The ML shifts like my car does when in W mode. There is no S - W mode switch in the ML

My indy and dealer both say my transmission is great... I had the fluid changed at about 53-55k miles.

Am I just being paranoid and shouldn't worry and things are completely normal?

I was thinking of going and driving a few 2000 C230's to see how they shift.

Anyone with both an ML and a C230K will be really helpful!!
 

·
Registered
Joined
·
1,675 Posts
I think anything thats not a 4 cylinder in the Benz world of things will be much smoother....heck even a W202 C280 is like butter on wheels. I know what you mean about the C230k shifting...what you explained is what mine does aswell.

I attempt to drive it in W mode most of the time because S mode is too rough and revs too high for no reason half of the time, if I just want to cruise around that is.
 

·
Registered
1998 C230 4 Dr 4 Cyl
Joined
·
28 Posts
http://www.benzworld.org/forums/w202-c-class/1330258-heart-shifting-morning.html

Go to the above URL. My experience with 202 tranny is described here. Also, one point not mentioned, is how to reset your tranny when it has memorized a shift pattern, which would include the hard shift from 1st to 2nd. Once the engine, et al, is fully warmed up, do this...from a full stop put the tranny into first gear (summer mode) and pull off with modest acceleration (2000 rpm max.) and then shift to second, third, fourth and then fifth. I find that this seems to reset bad thoughts in the transmission.
 

·
Registered
'99 2.3L Kompressor
Joined
·
1,944 Posts
Have you checked your engine and transmission mounts? Is your MAF fairly new? It can cause harsher shifts at times as it gets old. I am starting to wonder if mine needs to be replaced even though I have cleaned it about once a year. Maybe I will clean it one again since it has been about a year. I think in general the C230k tranmission shifting logic adaption software is just designed a bit harsh.
 

·
Registered
2002 ML320
Joined
·
1,951 Posts
Discussion Starter #5
http://www.benzworld.org/forums/w202-c-class/1330258-heart-shifting-morning.html

Go to the above URL. My experience with 202 tranny is described here. Also, one point not mentioned, is how to reset your tranny when it has memorized a shift pattern, which would include the hard shift from 1st to 2nd. Once the engine, et al, is fully warmed up, do this...from a full stop put the tranny into first gear (summer mode) and pull off with modest acceleration (2000 rpm max.) and then shift to second, third, fourth and then fifth. I find that this seems to reset bad thoughts in the transmission.
Thanks for the reply... I am well aware of the cold start and holding gears.

There is more to resetting the transmission than what you have stated. Here is a post I did earlier this month:

The quick way to reset the transmission and throttle body communications (which is where a lot of shifting weirdness lies) is to do the following step by step:

1. Get in and shut the door
2. Turn key to position 2 (right before the start position) DO NOT START THE CAR
3. Press the gas pedal to the floor... past the kick down point... see why I say DO NOT START THE CAR!??!
4. Hold the pedal there for 15 seconds
5. After 15 seconds while foot still planted, turn the key off but do not remove it
6. Release gas pedal... and get ready to be bored
7. Wait at least 2 minutes while not touching anything in the car, don't open the door even.
8. After the 2 minutes start the car and drive off normally... you should notice a difference in the shift pattern and smoothness.
 

·
Registered
2002 ML320
Joined
·
1,951 Posts
Discussion Starter #6
And thanks to benzonline and xvvvz... good to know that it seems normal... my MAF I should probably look at replacing... things just don't seem right sometimes with idle and even driving... it will feel like its missing a little bit... but I know its not... new plugs and no codes ever.
 
1 - 6 of 6 Posts
Top