Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
2005 E320 CDI, 2002 E55, 1987 300D
Joined
·
99 Posts
Discussion Starter #1
This is the second time the tranny connector started to leak on my car, the first time job went smooth but the second time I installed the connector, tightened up the bolt lightly, but the body still wiggled a bit in a seat so I gave it one more turn and the bolt slipped. Really pissed me off, does the tranny needs to come off now?
 

·
Registered
2005 E320 CDI, 2002 E55, 1987 300D
Joined
·
99 Posts
Discussion Starter #2
This is the second time the tranny connector started to leak on my car, the first time job went smooth but the second time I installed the connector, tightened up the bolt lightly, but the body still wiggled a bit in a seat so I gave it one more turn and the bolt slipped. Really pissed me off, does the tranny needs to come off now?
this is for my 2005 e320 cdi
 

·
Registered
2005 E320 CDI, 2002 E55, 1987 300D
Joined
·
99 Posts
Discussion Starter #3
this is for my 2005 e320 cdi
Well, took the pan off and looks like there is no way to remove the plate without taking out the valve body, Taking it to the dealer tomorrow...not a good feeling:crybaby2:
The bolt actually snapped in half. looks like it is made of very soft metal and cannot take much pressure.
 

·
Registered
mercedes w211 e350, B200 w245, w212 e63 amg 6.2L
Joined
·
1,010 Posts
you have stripped it mate.
They'll either have to replace the whole thing
OR
try to tap it and fix the thread up but it all depends how bad.
 

·
Registered
2005 E320 CDI, 2002 E55, 1987 300D
Joined
·
99 Posts
Discussion Starter #5
you have stripped it mate.
They'll either have to replace the whole thing
OR
try to tap it and fix the thread up but it all depends how bad.
t

It did not srip, the bolt snapped of in the main plate. I am assuming the valve body needs to come out? SUCKS!
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
1 - 6 of 6 Posts
Top