Mercedes-Benz Forum banner

1 - 20 of 62 Posts

·
Registered
2001 mercedes S430, 2010 mercedes E550 4matic
Joined
·
340 Posts
Discussion Starter #1
Hey guys, my tranny just started to act up out of the blue. It seems to be somewhat stuck in a gear and it doesn't feel like 1st or 2nd gear. It will not allow me to down shift using the auto shift nor will it allow me to change the W/S near the shifter. Has anyone had this problem and what do i do...plz help.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
The best course of action is to read out the fault codes.
 

·
Registered
2001 mercedes S430, 2010 mercedes E550 4matic
Joined
·
340 Posts
Discussion Starter #3
Where do i find the fault codes, unless your talking about taking it to the dealership to have it diagnosed?
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Where do i find the fault codes, unless your talking about taking it to the dealership to have it diagnosed?
Many places (workshops) can read the codes not just the dealers.
 

·
Registered
2001 mercedes S430, 2010 mercedes E550 4matic
Joined
·
340 Posts
Discussion Starter #5
according to other posts in the forum my tranny i believe is S430 2001 220.170 113.941 ME 2.8 722.632 NG70
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
according to other posts in the forum my tranny i believe is S430 2001 220.170 113.941 ME 2.8 722.632 NG70
I know it is the 722.6 transmission but in this particular case I cannot help without the fault codes.
 

·
Registered
2001 mercedes S430, 2010 mercedes E550 4matic
Joined
·
340 Posts
Discussion Starter #7
Ok i will get the code for you as soon as i can, thx hopefully today grrrrrrr
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Ok i will get the code for you as soon as i can, thx hopefully today grrrrrrr
Sorry, I know it is a pain especially when you cannot drive the car too far like this but there are simply too many possibilities, so the codes will narrow it down and make diagnosis much easier and accurate. Parts are very expensive and just throwing parts at the car is not a good way to go.
 

·
Registered
2001 mercedes S430, 2010 mercedes E550 4matic
Joined
·
340 Posts
Discussion Starter #9
Yes i understand, i guess its just impatience that sets in and i want answers right away. i apologize for that and will keep you posted. I'm going after work to get it diagnosed.
 

·
Registered
2001 mercedes S430, 2010 mercedes E550 4matic
Joined
·
340 Posts
Discussion Starter #10
Ok just had it diagnosed and the code that came up said pressure solenoid valve control circuit.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Ok just had it diagnosed and the code that came up said pressure solenoid valve control circuit.
You have two problems one is the electrics plate needs to be replaced and the second is a small spring on the pressure valve regulator that needs to be replaced, these threads from the 210 section (same transmission) will help you to understand;

http://www.benzworld.org/forums/w210-e-class/1446268-atf-transmission-control-module-99-e-6.html#post3538903
http://www.benzworld.org/forums/w210-e-class/1423078-722-6-pressure-regulator-spring-replacement.html
http://www.benzworld.org/forums/w210-e-class/1419452-transmission-woes-dealer-needed.html

And whilst doing all this you had best change the electrics connector as well;
http://www.benzworld.org/forums/w210-e-class/1369000-transmission-fluid-leak-connector.html#post2809739
 

·
Registered
2001 mercedes S430, 2010 mercedes E550 4matic
Joined
·
340 Posts
Discussion Starter #12
So your saying i need the conductor Plate, 13 pin connector and springs? I noticed at the beginning of the DYI he stated that he cleared the codes and the car ran fine for about a week, how are the codes cleared so i can drive it until my parts come in because i don't have another vehicle to drive and will not be able to get to work.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
So your saying i need the conductor Plate, 13 pin connector and springs? I noticed at the beginning of the DYI he stated that he cleared the codes and the car ran fine for about a week, how are the codes cleared so i can drive it until my parts come in because i don't have another vehicle to drive and will not be able to get to work.
You need a code reader to do that and one that will work on your car is not cheap. But you could try disconnecting the battery negative terminal for ten minutes. However if the spring is broken then this code deletion will be useless. With the conductor plate only it would work but the spring is the big problem here.
 

·
Registered
2001 mercedes S430, 2010 mercedes E550 4matic
Joined
·
340 Posts
Discussion Starter #14
I just called the Dealer for a price on the conductor plate and it was a very pricy part, they want $438 canadian funds WOW, is there another place that i can get that part from because i noticed they are a fraction of the price on ebay and it comes with the complete kit: plate, 13 pin connector and the filter and gasket.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
I just called the Dealer for a price on the conductor plate and it was a very pricy part, they want $438 canadian funds WOW, is there another place that i can get that part from because i noticed they are a fraction of the price on ebay and it comes with the complete kit: plate, 13 pin connector and the filter and gasket.
Do not buy from the dealer if you can avoid it, very expensive instead search for parts online, try autozone etc.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts

·
Registered
2001 mercedes S430, 2010 mercedes E550 4matic
Joined
·
340 Posts
Discussion Starter #19
Ok thanks. So are you almost sure that i need to change all parts or should i start with the 13 pin connector? Sorry just trying to reduce.
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Ok thanks. So are you almost sure that i need to change all parts or should i start with the 13 pin connector? Sorry just trying to reduce.
The 13 pin connector is the least of your worries, as long as it is not leaking. I only added it on because once disturbed whilst doing this repair the seal may not hold up afterwards.

The electronics plate and spring are the main problems.
 
1 - 20 of 62 Posts
Top