Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
1991 Mercedes 300E
Joined
·
467 Posts
Discussion Starter · #1 · (Edited)
91 300E. auto trans

ok so..got home car sat for about 1 to 1 1/2 hours then when i left, i got down the street and the car was reving high and it was like it wouldent steap into a higher gear to bring the revs down, then once i stopped at a light and the went the car was like it was stuck in a high gear, like it was bogging or not getting enough power, almost like it was stuck in a high gear this time and it was not shifting down.once this happened i got off the road in the parking lot and turned off the car. chacked all the fulids they all seemed fine, waited a few min, then turned it on and went, it was fine, shifting up and down with out problems. drove for a bit and then really did a bit to it, and it was fine up shifting and down.

what can this be do you think, anybody seen this before, im thinking its some kind of belt or clutch or something. a bottle of lucas was put in last service but wat does anybody think this could be.the whole tranny or a small peice like a belt or clutch or something. input needed
 

·
Registered
Mercedes E200 black. Mercedes 300ce - sold.
Joined
·
761 Posts
i would clean your throttle body and oil the linkages for a start.

my ce revved high and it was a little un-nerving round town.

took my air box off the car, and oiled any moving parts i could find on the throtle linkages, problem solved for me but i still had power so it maybe something else.

a few people on here seem to be having tranny issues so i would scour this 124 secttion for a possible solution

cheers
Ben
 

·
Registered
Joined
·
2,227 Posts
Could be some tranny oil pressure issue caused by the Lucas oil. See if it happens again. If it happens consistently then I would replace the tranny fluid.
 
1 - 4 of 4 Posts
Top