Mercedes-Benz Forum banner

21 - 27 of 27 Posts

·
Registered
2003 ML 350
Joined
·
182 Posts
The snapping / clunking noise can come from the torsion bar end as it did in my case. I had to do the job twice as the first time I only replaced the bearing but continued to clunk until I put synthetic lube onto the marked area.

2617166
 

·
Registered
2000 E 320 Wagon + 2002 ML 500 SUV
Joined
·
985 Posts
Here is that YouTube video I made on re-lubing the ML500 torsion bushings.
My nasty squeaks are still gone. I also did spray the white lithium grease on the forward bar to socket joint (near fwd crossmember,) but didn't show that in video.

Hope its helpful - David

 

·
Registered
w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Joined
·
2,196 Posts
error...
 

·
Registered
2000 E 320 Wagon + 2002 ML 500 SUV
Joined
·
985 Posts
Khomer, not sure your meaning here.

But I'm happy to report lots of driving recently and squeek has NOT reappeared.

I'm guessing that there is some 'wear in' on this Torsion Bushing (Delrin / Nylon) and if you install with insufficient lube or wrong type, that if it gets washed out BEFORE 'wear in' is fully accomplished, you get a nasty squeek going on.

Cheers - David
 

·
Registered
w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Joined
·
2,196 Posts

·
Registered
2000 E 320 Wagon + 2002 ML 500 SUV
Joined
·
985 Posts
Hey guys, I'm now 55 and find myself doing weird stuff too.

I'm told that all gets fixed in Eternity which is of great comfort to me !!!

PS: the nice thing is, my lovely wife, 55, does similar funny stuff and we laugh together about it.....
 
21 - 27 of 27 Posts
Top