Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
1999 Mercedes S500 Coupe
Joined
·
107 Posts
Discussion Starter #1
Team,
I have a newly acquired 1995 Cabriolet. Great car with a top problem i just cant find..... PO had removed all cylinders for rebuild. He indicated that the top worked until he reinstalled the cylinders. Here is what happens....
Unlatch the front,push top back, red light is on. The rear glass pops up to unlock, BUT... the glass will not raise. If i sneak a shim/stick under the glass and the latch, i can manually lift the lower section (back glass) and once in position, the top will work properly. It will stow into the trunk and all. The problem is that i don't know where to look to solve this issue. Looking at the diag chart attached.... B happens, but C does not..... If I move into position D by hand..... It will go the rest of the way. I also have to manually move it back to be able to close the top.

Please help here guys.... I am so frustrated.......

Thank you in advance.
 

Attachments

·
Premium Member
1993 300CE Cabriolet (mine) ; 1994 E320 Wagon (wife's) ; 1990 Benz 300E 2.6 (son's)
Joined
·
7,034 Posts
there's a buttload of limit switches that the controller looks at before it advances to each step. my guess is, the switch that tells it the bow is unlocked isn't working. that switch is in the bow lock hydraulic assemble thats mounted on the underside of the tonneau cover. its switch S84/8 on this wiring diagram, http://freescruz.com/.priv/W124/w124CD1/Program/ETM/2477200.pdf

and its not mentioned anywhere in ...
but this publically available version of the FSM is missing quite a lot of stuff.
 

·
Registered
1999 Mercedes S500 Coupe
Joined
·
107 Posts
Discussion Starter #3
there's a buttload of limit switches that the controller looks at before it advances to each step. my guess is, the switch that tells it the bow is unlocked isn't working. that switch is in the bow lock hydraulic assemble thats mounted on the underside of the tonneau cover. its switch S84/8 on this wiring diagram, http://freescruz.com/.priv/W124/w124CD1/Program/ETM/2477200.pdf

and its not mentioned anywhere in ...
but this publically available version of the FSM is missing quite a lot of stuff.

Thank you Left Coast!

I am not sure how to check it but will take it apart and see what I can see.... I thought it might be something in the quarters. Aren't there other switches there that would need to signal that the bow is moved? Or does the switch you mentioned need to be in a certain position first?



I bought a code reader on line. Any guidance on how to use it to check the top? It has a red, yellow and black wire. Assume red is power, black to negative and the yellow goes somewhere on the footwell connector?
 

·
Premium Member
1993 300CE Cabriolet (mine) ; 1994 E320 Wagon (wife's) ; 1990 Benz 300E 2.6 (son's)
Joined
·
7,034 Posts
AFAIK, there are three switches related to the bow. 1) the bow locked switch, this needs to show its unlocked before the bow will be lifted. 2) a bow raised switch, this is near the main top hinges, and indicates the bow is fully upright, so the next step can proceed. 3) finally, a bow down switch, also in the bow latch assembly, this indicates the bow is in the fully down position so the lock can be latched at the end of the cycle when the top is being put back up...


the top requires an entirely different setup to read the codes, via a plug under the back seat. I've never seen one of these code readers or adapters, there's also a kit with a 'breakout box' for the signals to the top controller, with lights on each switch and so forth.
 

·
Premium Member
2003 G500, 2000 SL500, 1995 E320 Cabriolet, 1980 TR8
Joined
·
1,066 Posts
Be sure the bow latch and its mechanism is well lubricated. The mechanism that actuates the two microswitches is complex and depends on a small spring to push the bow latch tab out slightly when it is hydraulically unlatched. I had a similar problem with my top so I took mine out, fully cleaned and lubed it, and then reinstalled it. The top worked again after that.

Also, the soft top troubleshooting manual that I have (from the image you posted, you probably have the same document) indicates that the connector to read the codes in in the passenger foot well. It also shows that the codes can read read with the usual pulse counter style readers. While I have not done it, if your red top light flashes indicating that a code has been set, I would look into reading the codes.
 

·
Registered
1999 Mercedes S500 Coupe
Joined
·
107 Posts
Discussion Starter #6
I took the rear bow latch out and I think there is a spring or something missing. Looking at the microswitch activation lever.... it doesn't seem to have anything to help actuate it. I see a small notch in it, I would assume there should be a spring attached. Does anyone have a close up pic of the latch?
 
1 - 7 of 7 Posts
Top