Mercedes-Benz Forum banner
1 - 11 of 11 Posts

·
Registered
2000 W210 E55 AMG, 2002 SLK32 AMG, 2007 W164 ML320 CDI
Joined
·
218 Posts
Discussion Starter · #1 ·
Hi all is me again I was still having problem with the car pulling (I got new tires and is been better but still pulls a little and seems to wobble a little too) I went to get another alignment done again today now the wheel is stright but pulling/wobble still there and the alignment guy told me that my outer tie rod is loose and worn but he saids it shoudn't cause any pulling or wobbling. I am wondering if is true and should I still replace the outer tie rod and see if it actually cause the pulling and wobbling?


p.s. I have post this on the AMG forum too but thinking here will have more ideas about it so I post it here too thanks!
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,631 Posts
What shop did you take it to? No reputable shop would align a car with worn and loose suspension parts (nor could they, really, because it wouldn't stay in alignment).

Have you owned this car since new? Any accidents in it's history? Has it done this since you owned it? Anyone else ever drive it?

Have it looked at by a competent shop (for that matter take it to the dealer, they'll align it better than anyone else anyway) and you'll at least find out what is wrong with it.

But yes, a worn-out tie rod can cause pulling and if it is badly worn it could also be part of a wobble. Really, you need to get it seen by someone who knows what they are doing.

Take care and enjoy the ride,
Greg
 

·
Registered
2000 W210 E55 AMG, 2002 SLK32 AMG, 2007 W164 ML320 CDI
Joined
·
218 Posts
Discussion Starter · #3 ·
yeah they told me too but I insist to do the alignment because my wheel was like an inch or two tilted to the right side I really can't stand it and the guy saids I would have to do another alignment after replacing the tie rod also. I didnt own the car since new but from the service history I didnt see any suspension work done before. After I got the car I have all control arm bushings replaced and the ball joints and it was fine for a long time. Only since a month ago it starts to pull and wobble and I have the dealer and 2 other shop check and find no problems with suspension but only until today the alignment guy told me the tie rod is lose and should be replaced.

by the way how to tell if is worn or badly worn? I mean when I turn my wheel to one end and I can see the outer tie rod where it connects to the wheel part with that rubber mount thing but when I touch it I can like shake the whole thing is pretty lose and I dont think is normal?
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,631 Posts
Is this what you're looking at?


If so that is the tie rod and it should be tight. Any movement is DECIDEDLY NOT NORMAL.

Replace it before it breaks and you are unable to steer the car.

And yes you'll have to have the car re-aligned after.

Where are you located by the way? I'm concerned that dealers and shops looked at the steering and suspension and didn't find any problems.

Take care and enjoy the ride,
Greg
 

·
Registered
2000 W210 E55 AMG, 2002 SLK32 AMG, 2007 W164 ML320 CDI
Joined
·
218 Posts
Discussion Starter · #5 · (Edited)
yeah thats the part I am looking and I think is upside down and when I try to touch the "U" shaped part it will shake is not tight at all I almost feel I can like pull it out or something and I can twist the rod to a point that the rubber mount thing will collaspe completly to whichever side I twist it and when I let go it goes back to center. I am located in toronto and the dealer was thronhill mercedes. they told me is suspension and control arm problem that the other shops told me those 2 parts are perfectly fine. And I got new tires and alignment and everythign the car still pulls until today the alignment guy told me my tie rod is loose. So do you think the tie rod is the actual problem greg? Thanks for your help this problem has been bothering me for a month already with no solution at all!
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,631 Posts
If it's loose, that's certainly a problem. Whether it's the cause or a symptom of something greater, you always start with what you know, and you know it's shot. ;)

You can DIY if you want, measure bolt center to the point where it reaches the link, then thread the new one in the same amount. You'll need a fork tool or separator, but it's not really that tough to change. However, your shop may give you a bit of a discount if they get to do (another) alignment too.

Take care and enjoy the ride,
Greg
 

·
Registered
2000 W210 E55 AMG, 2002 SLK32 AMG, 2007 W164 ML320 CDI
Joined
·
218 Posts
Discussion Starter · #7 ·
yeah I actually just went to the garage and see there is the inner rod connect to the outer one I didnt jack the car up so I cant really see the outer one but I can touch the inner one and I can twist it to either side very easily so I guess is not normal right greg? I guess I will just buy the parts and just bring it to the guy that told me that it should be replace if thats the case
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,631 Posts
You should be able to turn it a little, it's basically a ball joint like your shoulder on the tapered bolt end. But it should still be firm and have no play in it.
 

·
Registered
2000 W210 E55 AMG, 2002 SLK32 AMG, 2007 W164 ML320 CDI
Joined
·
218 Posts
Discussion Starter · #9 · (Edited)
so here from the pic I hold my hand on the circled part and I can twist the whole thing to either side for more then 1cm each side (I mean both side as twist towards to the front of the car and to the back of the car) when the car is on the ground. and if I dont twist it and try to shake it I can feel a little loose also. so is it consider bad?
 

Attachments

·
Registered
'01-E320 & 02-ST2
Joined
·
31,631 Posts
140 is the outer tie rod, other than firm rotational movement there should be no movement in it. My car it would be replaced. :thumbsup:
 

·
Registered
2000 W210 E55 AMG, 2002 SLK32 AMG, 2007 W164 ML320 CDI
Joined
·
218 Posts
Discussion Starter · #11 ·
yeah I think it should be replaced then so it should be able to rotate but it shoudnt be that easy I mean now is very easy to rotate it both ways and I can feel loose when shaking it. I really hope this is the problem that has been bothering me for a month about the pulling and wobbly wheel. thanks so much Greg for your help!
 
1 - 11 of 11 Posts
Top