Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
2010 E350
Joined
·
200 Posts
Discussion Starter #1
Hi~
I wonder if anybody has any suggestions of what I can look for or remedy the problem that I have.
I have a 1997 E420 that developed a ticking sound in the engine. Would someone have any suggestions, or is someone familiar with this problem. Other than the ticking sound car runs fine at 125,000.
Your help would be much appreciated as always............. thanks, donald
 

·
Registered
1994 E320 Wagon,1999 E320 Wagon,2000 E 320 Wagon, MGB Track/Rally, ,1988 300E ,more....
Joined
·
6,019 Posts
Search

citruspilot a member here on the forum.
m119 oil feed tubes
also on mercedesshop.com diy oil feed tubes.
Common problem on that engine sounds like a valve lifter gone bad.
ohlord:bowdown:
 

·
Registered
2010 E350
Joined
·
200 Posts
Discussion Starter #3
Thanks for your info. Do you know if I can refer to any diagrams or pictorials pertaining to changing the oil tubes?
 

·
Registered
1994 E320 Wagon,1999 E320 Wagon,2000 E 320 Wagon, MGB Track/Rally, ,1988 300E ,more....
Joined
·
6,019 Posts

·
Registered
1997 E320, 1997 S320
Joined
·
2,946 Posts

·
Registered
2010 E350
Joined
·
200 Posts
Discussion Starter #6
thanks again, the pictures and diagrams are very helpful.
people like you is what makes this board great!!!
donald
 

·
Registered
06 CLS500, Boeing-737, 04 Tahoe LT, 04 Infiniti G35 Sedan
Joined
·
257 Posts
Did I hear my name??? Yes the problem is most likely the oil feed tubes. The ends pop off and the oil pressure is reduced to the lower lifter making this noise. They are not hard to replace at all. Just need some good tools and a little patience. Be careful with the cam not to ding it once you remove it. And torque it to specs. The parts might cost about $150.00 as I remember to do each side................

Good luck.

Jeff
 

·
Registered
E420 ('97)
Joined
·
252 Posts
Sorry to bring back this old thread.

What do you guys think would be a fair price to replace all 8 cam oil line fittings on the driver's side of my M119? I don't think I can do it myself but a good independent mechanic quoted me $500 labor for this. I'm sure he'd do the job right but it seems a lot. On the other hand I'm not sure I want to risk taking it to some unknown cheap repair shop and having them do a bad job and mess something up on my engine...

reference: PeachPartsWiki: Replacing Cam Oil Line Fittings (Oil Guides)
 

·
Registered
1997 E420, 195K miles
Joined
·
14 Posts
Any idea why i would be going through oil feeding tubes every 3-4 weeks.
I have replaced my passenger side oil feeding tubes 4 times since JUNE. there is alway one of them that are going bad on that side every 3-4 weeks. I ordered the aluminum (blue ones) this time but will that fix the problem or is there something i need to look at.

PLEASE HELP. ANY IDEAS
 

·
Registered
E300TD 1997 W210 Running on WVO and a % of dino...
Joined
·
1,206 Posts

·
Registered
1994 E320 Wagon,1999 E320 Wagon,2000 E 320 Wagon, MGB Track/Rally, ,1988 300E ,more....
Joined
·
6,019 Posts

·
Registered
E300TD 1997 W210 Running on WVO and a % of dino...
Joined
·
1,206 Posts
Thank you Ohlord.
I am wondering as I got this loud tuk tuk on my cilinder head when I open the oil cap. Its too odd...
Its all good for 1o second when I start the engine then as soon as the pressure build up it sound like a steam engine... I thought this might be the cause, but hard to know if I got one of them to replace?
Cheers.
Happy weekend.
Olivier
 
1 - 12 of 12 Posts
Top