Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
1995 S320
Joined
·
39 Posts
Discussion Starter #1
Hi guys my 1995 s320 just had the tranny rebuilt in the process the tech
says my throddle body actuator is bad and the car is in limp mode , will not go out of 2nd gear, does this make sense? thank you for any help
 

·
Registered
1995 S320
Joined
·
39 Posts
Discussion Starter #3
no asr, and i am getting the part used for 255 , once he put the new tranny in there where many faults cant get the car out of limp , he determioned i need to replace throttle body
 

·
Registered
Joined
·
5,344 Posts
I've never heard of a non-ASR car going into the limp home mode but not sure if it's completely impossible or just exceedingly rare. A transmission problem could feel like the limp home mode. In any case the best clues you'll get are from the diagnostic system. Your car was an early adoptor of OBDII but it should have a 38 pin diagnositc connector as well from which you can read the codes yourself. Hopefully your mechanic has already read them to come up with this diagnosis. But it wouldn't hurt to ask and find out what they are. Your car has an electronic transmission and a diagnostic system for that as well - should be on pin 10.
 

·
Registered
1993 Mercedes-Benz 300SE & 1998 Mercedes-Benz C230
Joined
·
258 Posts
Might want to check to see if programming has to be redone due to new transmission install. Heard that newer cars require programming sychrnonization procedure. Just a thought.
 
1 - 5 of 5 Posts
Top