Mercedes-Benz Forum banner

501 - 520 of 533 Posts

·
Outstanding Contributor , Bob's Your Uncle!
-----'83 280 SL----- 5 speed....The PIG
Joined
·
29,507 Posts
I guess size required will depend on mounting space. If you can keep it upright, then 4 qt. will be the size of a WW fluid jug. Perfect!

If it's on some weird angle, you might not get a full 4 qts. in.

But Johnny........My fluid is probably over 5 or 6 years old. I rarely need it.

I had to dump some Isopropyl alcohol in to make sure it wouldn't freeze....because even that shit doesn't last forever.
 

·
Premium Member
1986 560SL with M120 V12 Engine, 1988 560SL Stock
Joined
·
10,196 Posts
Discussion Starter #502
I guess size required will depend on mounting space. If you can keep it upright, then 4 qt. will be the size of a WW fluid jug. Perfect!

If it's on some weird angle, you might not get a full 4 qts. in.

But Johnny........My fluid is probably over 5 or 6 years old. I rarely need it.

I had to dump some Isopropyl alcohol in to make sure it wouldn't freeze....because even that shit doesn't last forever.
They sell those in 2,3,4,5,6 qt same width and thickness, just different lengths. It will be placed under the right front fender just behind the headlight. I will fabricate a tube and filler neck that routs it into the engine compartment just like newer cars today. Unfortunately I don't know the real dimensions until I buy it. Not sure if the width includes the mounting flanges or the height includes the cap? It would be nice to get a 5qt so I could set the level sensor to trip at 4qt and fill it with a full bottle of fluid. I couldn't get even a 2 qt one inside the engine compartment.
 

·
Premium Member
1986 560SL with M120 V12 Engine, 1988 560SL Stock
Joined
·
10,196 Posts
Discussion Starter #503
They sell those in 2,3,4,5,6 qt same width and thickness, just different lengths. It will be placed under the right front fender just behind the headlight. I will fabricate a tube and filler neck that routs it into the engine compartment just like newer cars today. Unfortunately I don't know the real dimensions until I buy it. Not sure if the width includes the mounting flanges or the height includes the cap? It would be nice to get a 5qt so I could set the level sensor to trip at 4qt and fill it with a full bottle of fluid. I couldn't get even a 2 qt one inside the engine compartment.
 

·
Premium Member
1986 560SL with M120 V12 Engine, 1988 560SL Stock
Joined
·
10,196 Posts
Discussion Starter #504
Washer reservoir is due in today. In the mean time I have completed figuring out all the additional wiring and components required to make my Aux fans work properly and all parts are on order including required connectors from MB and parts to properly sheath new wires and tie them in place. I also found that my lower radiator hose was starting to get a bit soft to a new Silicone one was ordered and will be installed. So just when I thought I was close all that little crap added up to an additional $400. That will include the installation of a variable speed fan controller from Summit Racing to allow the AC system to over ride the electric radiator fan and turn it on 60% when the engine is idling and the radiator is not up to temp enough to turn the fan on itself. That will make it better mimic the mechanical fan in traffic situations. The rest of the stuff was a relay and hiring harness parts to allow the auxiliary fans to work with the M117 thermal sensors and shut down the compressor and turn on the Aux fans as needed. In addition it also includes replacement MD tie wraps that hold all these wires to the chassis as well as sleeving for the wires so it doesn't look like a hot rodders mess of wires under the hood. It will be a few weeks for all this stuff to arrive, at least the stuff from MB, but it will all be in time for the really hot weather when all that stuff is necessary. In the mean time we will finally get some 80° weather to test out what I have for the moment.
 

·
Premium Member
1986 560SL with M120 V12 Engine, 1988 560SL Stock
Joined
·
10,196 Posts
Discussion Starter #505
I'm obviously board. Waiting for my windshield reservoir to come in.
2632929
 

·
Premium Member
1986 560SL with M120 V12 Engine, 1988 560SL Stock
Joined
·
10,196 Posts
Discussion Starter #507
All is not rosy yet. Apparently I have an AC leak. After checking the fit of the WW reservoir, I took it for a spin and no AC. Tomorrow I will be picking up a UV light kit to hunt it down. Hopefully its not in the manifold.o_O Everything was working good up until yesterday so hopefully a shrader valve didn't seat right when I took the gauges of yesterday. Of course I should have checked them today before I put the gauges back on, but I forgot. They are not leaking now.
 

·
Premium Member
1986 560SL with M120 V12 Engine, 1988 560SL Stock
Joined
·
10,196 Posts
Discussion Starter #508
I was pacing the floor like an expecting father trying to figure out how to cut the top off. Finally tried something that was easy. I also realized that this reservoir also fits a shock MB pump perfectly.
 

Attachments

·
Premium Member
1986 560SL with M120 V12 Engine, 1988 560SL Stock
Joined
·
10,196 Posts
Discussion Starter #509
So it appears that I have no leak in my refrigeration system. What I did have was two fans acting as pull fans from the front and back. Basically making it like no fans at all. Apparently the R129 is wired backwards form the R107. Consequently I had the Auxiliary fan turning backwards and cancelling out the effects of the radiator fan. That makes the high side pressure shoot way up above 400PSI and the low side way up as well. And with low side pressures up at around 70PSI that actually becomes a heater. According to the manual today was ~25°C (77°F) when I tested, I should be seeing over 13.5°C (55.4°F) duct temperature. I was getting about 14°C (57°F) duct temperature. This could be just the effect of the R134 or maybe the condenser I put in sucks or possibly both. I am now well aware of one this the performance is better with lots of fans going. In any case, I believe its performing correctly, but as shitty as any 107 on R134.
 

·
Premium Member
1983 380 SL
Joined
·
2,823 Posts
So it appears that I have no leak in my refrigeration system. What I did have was two fans acting as pull fans from the front and back. Basically making it like no fans at all. Apparently the R129 is wired backwards form the R107. Consequently I had the Auxiliary fan turning backwards and cancelling out the effects of the radiator fan. That makes the high side pressure shoot way up above 400PSI and the low side way up as well. And with low side pressures up at around 70PSI that actually becomes a heater. According to the manual today was ~25°C (77°F) when I tested, I should be seeing over 13.5°C (55.4°F) duct temperature. I was getting about 14°C (57°F) duct temperature. This could be just the effect of the R134 or maybe the condenser I put in sucks or possibly both. I am now well aware of one this the performance is better with lots of fans going. In any case, I believe its performing correctly, but as shitty as any 107 on R134.
I would have thought the duct temperature should be considerably colder than 55F. Shouldn't it be in the 40's?
 

·
Premium Member
1986 560SL with M120 V12 Engine, 1988 560SL Stock
Joined
·
10,196 Posts
Discussion Starter #511
I would have thought the duct temperature should be considerably colder than 55F. Shouldn't it be in the 40's?
For most cars yes. But the 107 has absolutely the worst AC system I ever worked on. See the performance chart attached. But remember those are service maximums, I should be able to get 5° cooler with all new stuff. Last night I went out when it cooled down to 70° just like when I first tried it and dot 42° duct temp, I was getting 49-50°. Somewhere I lost 7 - 8 ° in the last 10 days. Charge seems to be fine pressures are perfect. A lot has to do with the condenser fan. I will be chasing that 7-8° over the next few weeks.

2633173
 

·
Premium Member
1986 560SL with M120 V12 Engine, 1988 560SL Stock
Joined
·
10,196 Posts
Discussion Starter #512
Nothing is simple with this car. Couldn't find a suitable place where I could mount a fan controller. I could have put it straight up but it would have blocked off the cold air intakes. So I spent all day making up a bracket that would hold it in place. Had to prop it up at an angle to let the hood close properly. Tomorrow I will fit the assembly in place and paint and really start the install.
 

Attachments

·
Premium Member
1983 380 SL
Joined
·
2,823 Posts
Nothing is simple with this car. Couldn't find a suitable place where I could mount a fan controller. I could have put it straight up but it would have blocked off the cold air intakes. So I spent all day making up a bracket that would hold it in place. Had to prop it up at an angle to let the hood close properly. Tomorrow I will fit the assembly in place and paint and really start the install.
Send it to me... I'll powder coat it. (y)

Where did you get the Clecos? I bought them to assemble the RV-12 I'm building. Clecos are one thing you can never have too many of.
 

·
Outstanding Contributor , Bob's Your Uncle!
-----'83 280 SL----- 5 speed....The PIG
Joined
·
29,507 Posts
Where did you get the Clecos? I bought them to assemble the RV-12 I'm building. Clecos are one thing you can never have too many of.
LOL. I've got a box of them from 20 odd years ago.

They do come in handy.
 

·
Premium Member
1986 560SL with M120 V12 Engine, 1988 560SL Stock
Joined
·
10,196 Posts
Discussion Starter #515
Send it to me... I'll powder coat it. (y)

Where did you get the Clecos? I bought them to assemble the RV-12 I'm building. Clecos are one thing you can never have too many of.
They fell off a truck.
 

·
Outstanding Contributor , Bob's Your Uncle!
-----'83 280 SL----- 5 speed....The PIG
Joined
·
29,507 Posts

·
Premium Member
1983 380SL, 2000 S430, 1991 420SEL (retired) - RHD
Joined
·
5,514 Posts
Send it to me... I'll powder coat it. (y)

Where did you get the Clecos? I bought them to assemble the RV-12 I'm building. Clecos are one thing you can never have too many of.
What are Clecos ?
 
501 - 520 of 533 Posts
Top