Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1986 420 sel
Joined
·
43 Posts
Discussion Starter #1
Hello All,

I was wondering what the white stuff on the back of the EZL ignition control module was and where can I get it. I bought a used one and it was suggested I add some. The car ran great for two weeks after I installed it and now it has this thing going on. It will sit at idle with economy gauge pegged to the left. Then after a period of time say a few minutes or more for no apparent reason it will lose vacuum and move to the center of the gauge. Going down the road it will so fine and then at times there will be no power to go up hills or accerate then it will come back again. Sometimes it will have to back fire a couple of times as if the timing is off. I dont know if it is related at all to the white stuff but I have been through everything else and am down to shooting in the dark. Could it be that it is losing its timing map and then regaining it due to the white stuff? I have replaced all the vacuum lines as well as the idle air hoses and injector cups etc and think if had a leak it would be consistant. When the economy gauge moves to the middle and I shut it off and start it again it will peg left again and run smooth. If anyone could help or point me in a good direction would appreciate it. Thanks Kimthecar
 

·
Registered
1993 300TE, 1995 E320 Wagon
Joined
·
1,895 Posts
From what I understand, the white stuff is heat sink paste, and it's available from electronic supply places (or they can tell you where to get it).

Heat Sink Compound / Paste

The EZL apparently runs kinda hot, and thus the paste to help throw off the heat energy. I would think you'd want to get some of the stuff ASAP. It could be that the circuitry is already fried a bit, and it might be that it gets hot and "clicks off" as you referred. The vacuum gauge is probably just a reflection of the engine running poorly when this happens. Hopefully the paste helps, but the EZL might have started to fail already.
 

·
Registered
1986 420 sel
Joined
·
43 Posts
Discussion Starter #3
white stuff

Thanks Elrojo,

It was another day of digging and trying different things, testing circuts and relays and the whole deal. Is what I am starting to think toooo. I have read somewhere here before that that is what it was for. About all I could do at the moment was to put some washers underneith it so there was at least a air gag heat could escape if that was the case but am thinking is too late and I need to find another one somewhere. It still had the plastic on it on the back so there is some there but may be not enough. Yesterday I put in a different throttle switch thinking it may not be getting the right info and I know my water temp is good so is looking like a new EZL. Yeah
 
1 - 3 of 3 Posts
Top