Mercedes-Benz Forum banner

1 - 15 of 15 Posts

·
Registered
2011 Mercedes E350 4matic Wagon
Joined
·
1,023 Posts
Discussion Starter · #1 ·
Not sure that i have mentioned it before, but it seems like its a bit worse from last year. Only does that when its warm/hot outside.
Any idea? I mean the ultimate solution, of course, is replacement.
Anyone else having, or heard about this?
Thanks!
See below what i mean

 

·
Registered
2002 C32 AMG
Joined
·
1,771 Posts
Yes, it is a common problem with the displays as they get older. I tried covering it with a sheet of cardboard to block from any sunlight thinking that might help, but it didn't. The only solution is a replacement. That, or you can just store the vehicle in a cool area. At least yours doesn't seem that bad. Mine gets a lot worse.
 

·
Registered
Joined
·
150 Posts
Boy do I love my extended warranty!

Going to get this fixed before I sell the C240. :)

Your MPG's look far better than mine!
 

·
Registered
2011 Mercedes E350 4matic Wagon
Joined
·
1,023 Posts
Discussion Starter · #5 ·
I actually get up to 33 mpg's on highway
I had extended warranty till 100K but its been gone now that i got 130K
ANy idea where i can find a used VDO, and do i have to go through dealership for the whole re-programming deal?

Boy do I love my extended warranty!

Going to get this fixed before I sell the C240. :)

Your MPG's look far better than mine!
 

·
Registered
2011 Mercedes E350 4matic Wagon
Joined
·
1,023 Posts
Discussion Starter · #7 ·
thats for sure...i am going to hold off on that since its ok when its cold...so not too concern yet, but when they start to disappear and not appear again then will spend some $$ on it
 

·
Registered
02 C32, 08 C350, 00 CLK320 (sis'), 01 ML430 (gone)
Joined
·
1,698 Posts
use a sun shade when park the car in the sun. it should help prevent the pixel dying quicker.

if you don't have the extended warranty go to a junk yard and look for a VDO that doesn't have the same issue, but you will need to take both VDO apart and swap parts because once the dash is used they cannot be programed for another car. you will need a new dash if you want to replace it.
 

·
Registered
2011 Mercedes E350 4matic Wagon
Joined
·
1,023 Posts
Discussion Starter · #10 ·
Thanks Frank, i saw that somewhere else..and its a good point!
The sun shade doesnt really do much, been using since day one....still happening
 

·
Registered
2002 C240
Joined
·
16 Posts
Same problem here. In the morning when going to work it's bright with every pixel lit but when coming home from work, when it's 95 outside, it looks almost identical to the pic that Eesjunin posted. Luckily we're getting ready to get parking on the next level down (covered) so maybe that will cure it or at least prolong it's life.
 

·
Registered
2003 C230 Coupe
Joined
·
1 Posts
Back from the dead. Has anyone figured out how to repair this without having to replace the entire cluster?
 

·
Registered
2002 C240 Auto (Hijacked by criminals), Now I have a 2005 C200 Auto.
Joined
·
235 Posts
 

·
Registered
05 benz s500 4matic
Joined
·
5 Posts
very easy to fix! go to e bay and type c class cluster lcd then you will find it right away.it coast to you $127.just get it and replace it
 
1 - 15 of 15 Posts
Top