Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
1985 500sel
Joined
·
19 Posts
Discussion Starter #1
MY ECONOMY GAUGE WAS ACTING CRAZY SOMETIMES WEN I STARTED THE CAR IT WOULD STAY IN THE MIDDLE INSTEAD OF ALL THE WAY BACK. THE CAR WOULD ALSO SHAKE A LITTLE. DOES ANYONE KNOW WHAT WAS CAUSING THAT?[8][}:)]
 

·
Registered
1988 420 SEL
Joined
·
159 Posts
VACUUM OPERATED

PimpinBenzo - 3/3/2005 4:07 PM

MY ECONOMY GAUGE WAS ACTING CRAZY SOMETIMES WEN I STARTED THE CAR IT WOULD STAY IN THE MIDDLE INSTEAD OF ALL THE WAY BACK. THE CAR WOULD ALSO SHAKE A LITTLE. DOES ANYONE KNOW WHAT WAS CAUSING THAT?[8][}:)]
IT'S VACUUM OPERATED, SO MAYBE YOU HAVE A VACUUM LEAK OR A LEAK IN THE INTAKE MANIFOLD.
 

·
Registered
420 SEL
Joined
·
223 Posts
You have a vacuum leak, mine did the same thing and I found the hose to the modulating valve on the g/box had come loose from a rubber fitting that had deteriorated. Check all your hoses and you will find it.
[:)]
 

·
Registered
420 SEL
Joined
·
223 Posts
You have a vacuum leak, mine did the same thing and I found the hose to the modulating valve on the g/box had come loose from a rubber fitting that had deteriorated. Check all your hoses and you will find it.
[:)]
 

·
Registered
89 420 SEL (sold), 01ML320 (sold), 03 S430 4MATIC, 06 ML500
Joined
·
580 Posts
I think your plugs are fouled up and this is not creating enough engine vaccuum. Check the state of the plugs for oil burn first!
 

·
Registered
1984 500sel
Joined
·
35 Posts
regarding vacuum leaks. I'm pretty sure mine is shot. the economy gauge, door looks, ac stuck on low. Are there any other functions the vacuum system does? Is this just a matter of hoses or would motors and pumps be envolved. lastly is this an easy project that an average person could do?
 

·
CH4S Admin , Outstanding Contributor
1985 500SEC, 1991 190E 2.6.
Joined
·
42,992 Posts
On U.S. / LHD cars, vacuum hoses connect to a white plasic fitting at the front of the fuse box. Check if a hose has come off.
 
1 - 8 of 8 Posts
Top