Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
86 420 sel 90kms
Joined
·
48 Posts
Discussion Starter #1
I have been doing some reading on the B2 piston and would like to get some insight into it.I am getting slight flare in the first shift in the morning as I pull out of the driveway.I am finding that once the transmission is fully warmed up all seems to be good(the tempeture here is -20 to -30 centigrade).I let the car warm up for 10 minutes in the morning with the transmission in neutral and then take it very easy until i reach 80 degrees on the temp gauge,also I can slightly feel the downshift sometimes at 70 kms/hr(but ever so slightly),fluid level is okay,fluid changed every 30k plus filter.my question is ,can something be adjusted,is it the B2 piston,or should I order a rebuilt from Adsit(they have good prices--any comment on them)---tell me your transmission stories.
 

·
Registered
85 300 SD
Joined
·
276 Posts
when my B2 piston went out i knew it was something huge...i was about 20 miles from the house, went to pull away from a redlight that was slightly uphill...i gave it some pedal, and got about 15 feet and just heard a loud knock, and then my engine lost 1st gear....i crept it home and had to stop at a few more redlights before getting back....it would go into first, but you had to liiiightly touch the throttle and take off very slowly, or it would slip badly....once i got up into 3rd gear, youd have never thought there was any problem at all, it rode out just like normal...the B2 only affects 1st and 2nd gears....maybe there are varying degrees of severity when this piston goes out, but im not sure....ill just add that i know nothing about transmissions...mine just quit on me one day and someone suggested it could possibly be the B2 piston....i read the tutorial on replacement, acknowledged that the symptoms listed and the ones i was having were the same....then i ordered the parts and went to work....i figured, what the hell, its much cheaper than a rebuilt tranny so why not see if this could be it...it worked, now the transmission is smooth as ice
 

·
Registered
2006 500SE, 1972 280SE
Joined
·
345 Posts
I experienced a B2 Piston failure last year on my Euro 83 500SEL. The transmission had a slight flare but really not that perceptible. i didn't think it registered as something to worry about.

It also had some delay in going from P,N,D to reverse. I don't know if that was related.

I was driving home when after hitting a small bump (a *very* small bump - a pothole about 2 inches deep and 4 inches accross), I lost all power to the wheels. The engine revved and revved. I shifted to 2, B, nothing. Then it slipped like crazy and engaged halfway, letting me idle home (i was about 200 yards away).

It was a $300 fix and the car performed fresh and healthy but it is a crippling problem when it hits.
 

·
Registered
MB 1985 W126 300SEL, 1991 MB W124 260E, 2007 MB W209 CLK200, 1999 Skyline R34 GTT Veilside,
Joined
·
342 Posts
Planning of fitting my K1 spring set tomorrow. i hv d same problen during morning start. Stuck on d same gear from standing start & revs up to 5000rpm before it chang up. Any below that rev, it just coast freely. Can d B2 piston be replaced while doing d K1 spring, filter & oil change or it requires dropping the whole gearbox? The transmission recently rebuilt by an Indy though not so perfectly.
 
1 - 4 of 4 Posts
Top