Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1990 560SEL, 1999 SLK, 2005 BMW 525I
Joined
·
208 Posts
Discussion Starter #1
My '90 SEL has developed a peculiar rise in water temp. At sustained speeds of 80-90 mph with the ac on the temperature will rise to approx 105-110 centigrade. The two auxiliary fans do not seem to come on until that temp.
I have been told that these fans should come on as soon as the ac is turned on.
I am not loosing any coolant, I can think of causes for the rise in temp vs speed, such as colapsing hoses restricting the coolant flow. I am a bit puzzled, any help is appreciated.
 

·
Registered
W140 S600 300D300SD
Joined
·
226 Posts
rising temp

hello sunny,
1st of all it is normal that the temp rises as you speed-up but it has to be just a minor rise of 5 to 10 degrees only, ive had such problems on my mercs, thats why i had my aux fans re-wired and installed a relay and connected it to my a/c compressor everytime the compressor turns on it turns -on the aux's as well, with this set -up the aux fans runs more often rather than the orig set-up of turning on when the temp gets more that 90 to 100, the car operates more cooler, in addition to this i also saw on the net someone drilled holes on his water termostat 5holes to be exact, i applied this to mycars and the drop in temp was really evident, before doing the holes in still traffic my car reaches 100 degrees, now it barely reaches 95 it stays in th 90-93 mark perfect in our tropical climate here. before any modification when i speed -up my temp reaches 105-100 but now it never happens, my temp stays in the 95 mark even if i drive hard
 

·
Registered
Two '87 570SECs, one '87 560SEL
Joined
·
4,448 Posts
did you add dual electric fans to the SEL? My dual fans block some air flow and at higher speeds the temp goes up a little, just like yours.

Please fill out your profilel - where are you located???
 
1 - 3 of 3 Posts
Top