Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
94S420,98S320,95740I
Joined
·
210 Posts
Discussion Starter #1
i have a problem when driving in city my temperature gauge goes up to 105 degrees celcius,but as soon as i hit the freeway a drive at 100mph the temp goes down to 80. what is the normal temperature anyway during drivng?.i have done oil and radiator flush ,still same problem. is it the fan? i also checked all the fuses are ok. thanks
 

·
Registered
1995 S500
Joined
·
7 Posts
Misery LOVES company! Mine does the same thing. That was checked while she was at the dealer last week. Among the laundry list of suggested repairs, they suggested replacing the temp sending unit (they do not recalibrate- which is strange because I had to have the temp unit recalibrated in a Lincoln that I once had- much cheaper in parts AND labour...)

Nope, they want to "try" fixing it with the $400 part and "go from there" if that doesn't work[B)]

If you get another (better?) opinion, LMK!

-Bill
 

·
Registered
Joined
·
113 Posts
One of my 300SE's did pretty much the same thing. I changed out the thermostat (about $50 if a remember correctly) and the problem went away. My temperature now stays with 5 degrees of 80.

Good luck..
 

·
Registered
1995 S600 (sold)
Joined
·
1,127 Posts
My S600 ran very hot, even in cold weather. Changed viscous fan clutch (VFC) recently, and so far, engine temp has not gone over 85 - 87 C. It would sometimes hit 110 C when it was 38 F outside. Instructions on how to change VFC on my web page. Click on the link in my signature.
 

·
Registered
2003 CL600
Joined
·
455 Posts
Check this out

http://pages.prodigy.net/jforgione/MB_CTS.html
http://pages.prodigy.net/jforgione/MB_S500.html
 
1 - 6 of 6 Posts
Top