Mercedes-Benz Forum banner

1 - 19 of 19 Posts

·
Registered
2002 Mercedes G500 & 2005 BMW 745Li
Joined
·
117 Posts
Discussion Starter #1
My G is getting a TC Neutral problem 1-2 times a week.
It wasn't this bad when I purchased this vehicle, but the error keeps coming back every other days.

Which part do I need to replace? TC controller module or the whole TC??
How much would I expect for Part & Labor?

Thanks for your input.

Other than the TC, my G500 is doing great.
 

·
Registered
CL600, GL450 and G55 AMG
Joined
·
4 Posts
Me too

Im also having the same problem for the past week. Ive been able to drive and everything seems ok, its the annoying sound the car makes when you have your door open. Is this a serious problem ? One thing I did notice is that my gas consumption has been really bad as of late. Do I need to bring in my G to fix this TC problem and what is the TC? :confused:
 

·
Registered
02 G500
Joined
·
2,254 Posts
its just a switch.... ive had 3 of them..

Make sure you dont play with it to much. one time mine stuck inbetween H and L when the switch was acting up... Its a cheap design if you ask me... but you know us americans... we cant have a lever to pull, it wouldnt look right..
 

·
Registered
2004 G500, '95 discovery '96 525i.
Joined
·
11 Posts
ditto. oddly enough it happened for the first time sunday, and has happened twice more this week so far. can someone please tell me the best way to make sure the TC is in high? the manual says put it in neutral at less than x mph, then switch to high.
do you have to be moving?
 

·
Registered
02 G500
Joined
·
2,254 Posts
unless you have been in low range its in High... easy way to notice is the indicatior is blank is to put it in drive. Fist gear is only good for like 8 mph. you will know for sure if its in low... it makes the G feel like it has 800 hp ;)
 

·
Registered
2002 Mercedes G500 & 2005 BMW 745Li
Joined
·
117 Posts
Discussion Starter #7
I know it's in H mode even the TC in Neutral error message displayed on my cluster. It's just annoying me, and it becomes a regular error messages. Used to be once a month deal, but becomes once a week which giving me a worry.

90% of time that I got this error message is that right after I park my G. It seems my G doesn't like me to sudden engine stop or something.
 

·
Registered
Joined
·
42 Posts
I have a 2003 G500 with 12,000 miles on it and the same TC in Neutral problem just happened to me tonight. When i pull up the hand brake it turns off but as soon as i put it down with the door open it beeps.
Is this something i need to bring to the dealer right away?
 

·
Registered
2002 Mercedes G500 & 2005 BMW 745Li
Joined
·
117 Posts
Discussion Starter #9
Shift your gear to Neutral and push Low button for 10 or more seconds and then hit High button. It will put you back into H mode. If it doesn't work, keep doing it until you get H mode displayed on your cluster.

Unless you have a MB warranty left, you shouldn't run to dealer unless you want to spend $$$.
 

·
Registered
Mercedes G Brabus
Joined
·
678 Posts
annyoung said:
Shift your gear to Neutral and push Low button for 10 or more seconds and then hit High button. It will put you back into H mode. If it doesn't work, keep doing it until you get H mode displayed on your cluster.
Unless you have a MB warranty left, you shouldn't run to dealer unless you want to spend $$$.
Just a question (no disrespect) but I see you have a G500 and a 745 Li ok ? If this problem is getting on your nerves would it really be such a nightmare to bring the G your friendly local Mercedes garage to get it fixed ? Life is to short to get annoyed over something like that.
 

·
Registered
2002 Mercedes G500 & 2005 BMW 745Li
Joined
·
117 Posts
Discussion Starter #11
Well, I don't want to waste my money unless I know exactly what I'm doing. I've already contacted to one of MB technician that I know and waiting for his answer. Like other people on this forum mentioned, it should be an easy fix.
 

·
Registered
Joined
·
42 Posts
My vehicle was purchased originally with the extended warranty for an additional 3 years. Hopefully this will be covered when they look at it on Monday.
 

·
Registered
2002 G500
Joined
·
25 Posts
I love this Forum, just bought a 02 three months ago and not ever owning one, I thought the beeping sound and TC Neutral indicator light going off when the door was open was normal. I pressed the L for 10 seconds and then H and this fixed the problem. My car is still under warranty but the dealer never bothered to tell me that it could be a problem. I will definitely monitor it and if it persists and becomes a problem will be getting it addressed under my warranty.

Thanks everybody,
Mario:)
 

·
Registered
Joined
·
202 Posts
..........there IS a transfer case recall in the pre-2004 G55 and G500's. Your dealer has been instructed tonly replace your transfer case on the third viit for the same problem. If your car is under warranty, head to dealer until your TC is replaced, otherwise you are going to shell out big bucks on your own.

Ted
 

·
Registered
G 500
Joined
·
1,079 Posts
boboydds said:
I have a 2003 G500 with 12,000 miles on it and the same TC in Neutral problem just happened to me tonight. When i pull up the hand brake it turns off but as soon as i put it down with the door open it beeps.
Is this something i need to bring to the dealer right away?
Your Dealer should replace the Controller unit for the TC. Not complicated. Fast Job.
 

·
Registered
111.010 121.942 202.033
Joined
·
1,850 Posts
My dealer's estimate was $852.86 - luckily I'm covered by warranty.

The part # is 463-545-25-32. At Duval Motors the cost is $346.32, my dealer prides themselves on overcharging for everything and wanted $505.40.

Duval Motor Cars

My dealer's labor estimate was $347.46 total (don't know the hourly rate). I'm guessing this job could actually be done by a monkey, or possibly a chimp, in under an hour.

The same dealer also wanted a $13X.xx to change the city light in my headlight. I politely declined (actually I made a reference to smoking crack cocaine). I've replaced an entire headlight (basically the same steps) myself in 20 minutes.

Moral of the story - don't go to my dealer.
 

·
Registered
'72 350sl & g500
Joined
·
597 Posts
what dave, you say go to fletcher? k! ill go next week! actually.... thats true... drivers window regulator is acting like the pass did, and the drivers side blinker (in mirror) isnt working. It a loose connector, but i dont wanna take it apart... being a free "repair" and all....
 

·
Registered
Joined
·
2 Posts
Loving all the replies just incurred this issue a couple of weeks ago (TC in Neutral but running well though). I had not drive her in 2 weeks and noticed I didnt see the H and the constant sound when and after opening door. I purchased my G500 in 04 but its an 02, 65K miles. The display shows nothingnwhere H would normally be displaying. Will use the method suggested to see if the H appears again.
 
1 - 19 of 19 Posts
Top