Mercedes-Benz Forum banner
1 - 5 of 5 Posts

·
Registered
190E Benz
Joined
·
109 Posts
Discussion Starter · #1 ·
Im just wondering whether there is a trick to installing the new tail light?
Got the old one out fine, but the new one (cos of the new rubbers) wont go in properly ::cry:: Can anyone help? Need to get it in soon cos i need to be able to drive the car! thanks
 

·
Registered
1987 Mercedes 190E 2.3 8V
Joined
·
38 Posts
Reinstall the old assembly to see if it is the new rubber trim or if you are simply doing something wrong. The gasket should not interfere with installation.
Good luck.
reubengeg
 

·
Registered
190E Benz
Joined
·
109 Posts
Discussion Starter · #3 · (Edited)
reubengeg said:
Reinstall the old assembly to see if it is the new rubber trim or if you are simply doing something wrong. The gasket should not interfere with installation.
Good luck.
reubengeg
I have done this, got it back together fine, but its not sturdy now, like it moves a little from the outside. This may sound like a silly question, but is the rubber meant to sit on the outside? It just doesnt sit as nice as the other one does and im not sure if thats how its meant to be cos its slightly different being a generic tail light, or what?
 

·
Registered
190e 2.3 widebody
Joined
·
94 Posts
Hi, i think i remember you saying you were goiung to buy a non genuine light. i also had difficulty fitting non genuine, the rubbers were too thick. i squashed them carefully by putting weight against the outside lens, then started all nuts and tightened them evenly, worked fine.
 
1 - 5 of 5 Posts
Top