Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I had to get my left rear shock absorber replaced on my 2008 GL 320. Now the front sounds a little fishy when I do a hard slow turn. Sometimes when I'm at the stop light, the truck seems that it levels itself automatically, which feels a little strange...or a little cool depending. My question to you guys is whether any of you have had suspension problems with your 2007 GLs? Enquiring minds want to know:confused:
 

·
Registered
Joined
·
304 Posts
No broken suspension yet, but the front shocks "feel" a little soft. I get a double bounce when backing off my driveway, but just the front end. Probably the bean counters ordering the shocks, forgetting that this is a 6,000lb truck.
The handling doesn't seem compromised by it.
How did you discover the left rear shock died?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4 (Edited)
I listen more attentively now that they replaced the left rear shock under warranty. I notice it when it goes over a bump (driveway), railroad tracks, or pot holes. I can also tell when I do a hard slow turn.:confused:
 

·
Registered
Joined
·
1 Posts
Problem shock on the front

My dealer told me there was a known issue with the double bounce and knocking at slow speeds. Now having issues with front passenger shock after it went in the shop on the 08 GL recall. They claim they did nothing, but now worried about vibrations and think shock is the cause. How can you tell if the air shocks are bad?
 

·
Registered
Joined
·
1 Posts
mercedes benz 2006 GL 320

I find it to go okay for a few klm then it starts bouncing like a kangaroo what does that mean anyone?
 

·
Registered
Joined
·
1,172 Posts
If the shock has a noticeable clunk. Then the shock portion is bad. If it has ride height issues it could be the air spring.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,172 Posts
Agreed. I had a loud clunk coming from my right front strut. I replaced it and now no clunk. When we took it apart and the shock portion itself was worn. One thing we did notice is that the previous owner had used an ADS strut but cut the wire harness on the ADS portion as my car doesn’t have it. That could have had something to do with the noise as well. All good now.


Sent from my iPhone using Tapatalk
 
1 - 9 of 9 Posts
Top