Mercedes-Benz Forum banner

1 - 16 of 16 Posts

·
Registered
2000 E430 4Matic, 2007 R320 CDI, 2012 E63 P30, 2013 SLK250
Joined
·
440 Posts
Discussion Starter #1
Has anyone in the US had success registering for EPC access recently?
I've tried on several different occasions in the last few weeks but can't get past registration after entering my registration information.
I get this error:
SORRY: THERE WAS AN ERROR PROCESSING YOUR TRANSACTION. PLEASE TRY AGAIN LATER.
If there is not something obvious, I will submit a trouble request to the site admin..
Thanks,
-Robert
 

·
Registered
1959 220S cabriolet, 1983 240D original owner, 1999 E300 turbo diesel, 1988 560SL, 2003 SLK320
Joined
·
3,513 Posts
I just renewed to check to make sure everything was working. Had no problems and I'm now renewed through 2015.
 

·
Registered
2000 E430 4Matic, 2007 R320 CDI, 2012 E63 P30, 2013 SLK250
Joined
·
440 Posts
Discussion Starter #3
renewing may be different since your registration info already exists in the system.
FWIW, steps I took to register:
1. choose 'subscribe'
2. click 'agree' to disclaimer statement.
3. I chose the free 365 day subscription option.
4. entered registration info including CC info.
5. clicked 'continue'
6. error displayed in red on top of registration page.
-Robert
 

·
Registered
Mercedes-Benz 1998 E320 - 160,000 Miles Strong
Joined
·
215 Posts
renewing may be different since your registration info already exists in the system.
FWIW, steps I took to register:
1. choose 'subscribe'
2. click 'agree' to disclaimer statement.
3. I chose the free 365 day subscription option.
4. entered registration info including CC info.
5. clicked 'continue'
6. error displayed in red on top of registration page.
-Robert
I'm having a Java applet problem I'm thinking this program was/is designed for XP i gotz me some win7 64
 

·
Registered
2000 E430 4Matic, 2007 R320 CDI, 2012 E63 P30, 2013 SLK250
Joined
·
440 Posts
Discussion Starter #5
the Java part shouldn't come into play until after the registration. Were you able to get through registration?
-Robert
 

·
Premium Member
'72 350SL, '85 300D, '98 E320, '19 Subaru Outback (sold '14 GLK250)
Joined
·
10,323 Posts
I'm having a Java applet problem I'm thinking this program was/is designed for XP i gotz me some win7 64
Works fine for me on Win 7 64bit laptop. You may want to in and delete (uninstall) all versions of Java and start fresh.
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,631 Posts
Last time I checked, it was actually certified for Internet Explorer, so if you're using a different browser, that might also be an issue.
 

·
Registered
Mercedes-Benz 1998 E320 - 160,000 Miles Strong
Joined
·
215 Posts
Yeah I got registered no prob, its the java that's gets stuck at 80% then just shuts down I'm going to reinstall java and see if that's going to fix this. All this cause of one stupid part @#$! Me
 

·
Registered
Dallas, Texas
Joined
·
7,698 Posts
Yeah I got registered no prob, its the java that's gets stuck at 80% then just shuts down I'm going to reinstall java and see if that's going to fix this. All this cause of one stupid part @#$! Me
You need to uninstall all Java stuff then install what is recommended by EPC. Later when prompted for updates gently ignore them. Practice safe computing.
 

·
Registered
2000 E430 4Matic, 2007 R320 CDI, 2012 E63 P30, 2013 SLK250
Joined
·
440 Posts
Discussion Starter #12
Any of you chose the 'Free 365 days' option when registering?
I'm beginning to think that may be my problem. Perhaps they are not offering a free subscription anymore?
-R
 

·
Registered
Mercedes-Benz 1998 E320 - 160,000 Miles Strong
Joined
·
215 Posts
Any of you chose the 'Free 365 days' option when registering?
I'm beginning to think that may be my problem. Perhaps they are not offering a free subscription anymore?
-R
I got signed up yesterday. so I don't think that would be the case. maybe its your Internet explorer settings I made that page a trusted site, also I disabled my firewall.
 

·
Registered
2000 E430 4Matic, 2007 R320 CDI, 2012 E63 P30, 2013 SLK250
Joined
·
440 Posts
Discussion Starter #14
I finally got registered and the only thing I did different was to select the paid option.
Spadwaller, you were able to register using the free option?
-Robert
 

·
Registered
Mercedes-Benz 1998 E320 - 160,000 Miles Strong
Joined
·
215 Posts
I finally got registered and the only thing I did different was to select the paid option.
Spadwaller, you were able to register using the free option?
-Robert
I did the "Free" option that requires you to put in a valid Credit Card :confused: I better not see a charge on my card.
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,631 Posts
I did the "Free" option that requires you to put in a valid Credit Card :confused: I better not see a charge on my card.
If you do you'll be the first I've heard of.
 
1 - 16 of 16 Posts
Top