Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
1997 C200 AUTO (W202)
Joined
·
3 Posts
Discussion Starter #1
hey guys,

can anyone help me with identifying a noise?

i have a rattle which sounds plasticky or like a heat shield but..
it SOUNDS like its coming from the thermostat! you can feel it through the thermo casing and it seems quite localized.
its more prominent when cold but then it will go quiet when the motor is up to temperature but you can still hear it faintly.
replaced the thermo in case it was loose internals threatening the waterworks but it's still there.

1997 C200 AUTO

is this just 'one of those things'? this is my first Mercedes so i don't have a clue about this type of engine.

oh and BTW, had it 2 days - MAF sensor's in the post lol. :)
 

·
Registered
1997 C200 AUTO (W202)
Joined
·
3 Posts
Discussion Starter #3
i replaced the thermostat earlier today for elimination purposes, but i couldn't really tell if it made any difference since the motor had been up to temp all day. i'll have to see what the morning brings and go from there.
 

·
Registered
1995 W140 S320 LWB, 1983 w126 280SE Euro
Joined
·
111 Posts
hey guys,

can anyone help me with identifying a noise?

i have a rattle which sounds plasticky or like a heat shield but..
it SOUNDS like its coming from the thermostat! you can feel it through the thermo casing and it seems quite localized.
its more prominent when cold but then it will go quiet when the motor is up to temperature but you can still hear it faintly.
replaced the thermo in case it was loose internals threatening the waterworks but it's still there.

1997 C200 AUTO

is this just 'one of those things'? this is my first Mercedes so i don't have a clue about this type of engine.

oh and BTW, had it 2 days - MAF sensor's in the post lol. :)

did you replace the belt tension shock that connects right to the thermostat housing? I had the same issue and it was exactly this problem it looks like a mini shock absorber
 

·
Registered
1997 C200 AUTO (W202)
Joined
·
3 Posts
Discussion Starter #5 (Edited)
a Mercedes mechanic did tell me that it could be that little shocker, and the thermo made no difference to the noise when i cold started it.

but since today... my rad light comes on now and again. might it need bleeding or is it self bleeding? i filled it back up after replacing the thermo and it keeps cool so maybe its an air lock somewhere.

and if anyone knows where the fuse for the rear window demister hides that would be helpful also cos mine doesn't work at the moment.

thanks guys.
 

·
Registered
2002 ML55 AMG, 2005 Chrysler Crossfire Coupe Limited, 1999 C280
Joined
·
4,714 Posts
hey guys,

can anyone help me with identifying a noise?

i have a rattle which sounds plasticky or like a heat shield but..
it SOUNDS like its coming from the thermostat! you can feel it through the thermo casing and it seems quite localized.
its more prominent when cold but then it will go quiet when the motor is up to temperature but you can still hear it faintly.
replaced the thermo in case it was loose internals threatening the waterworks but it's still there.

1997 C200 AUTO

is this just 'one of those things'? this is my first Mercedes so i don't have a clue about this type of engine.

oh and BTW, had it 2 days - MAF sensor's in the post lol. :)
Sorry to hear about your problem.

The rattle may be your idler pulley.

It's the top most pulley located in the centre of the engine.

Just a thought...:)
 
1 - 7 of 7 Posts
Top