Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter #1
HI guys got a strange 1 and with the cold setting in I need to sort this!
When I have heater in I get hot air but the fan works fine no1 no2 but 3 and 4 rattle while spinning.
Do you think the bearing is shot on the fan motor?
Cheers dan
 

·
Registered
Joined
·
94 Posts
Discussion Starter #3
Ok so I found out that the fans noise is from a crack in the blade so at fast speed it opens up and rubs on sides so now I can sort that one!
The red light is for the heater booster but I can't hear it running so now my question is does anyone know where it is so I can have a look at it
Cheers dan
 

·
Registered
Joined
·
94 Posts
Discussion Starter #6
Ok and another problem occurred now lol
The fan only works on no4 speed like the resistor as gone but this was working fine an hour ago before mending the cracked fan
Any help would be apprieciated
Dan
 

·
Registered
Joined
·
2,384 Posts
The available info on the auxilliary heater and boost.... theres a number of variations with no specific information on which applies.

Sevice info
Test info
Wiring info

I've attached the DataCards for your vehicle which includes all of the equipment codes for the delivery spec.
 

Attachments

·
Registered
Joined
·
94 Posts
Discussion Starter #8
Thanks for the info it appears that I don't have a booster heater just the button lol
Also any ideas on the new problem of only working on no4 even though it was fine before
Cheers dan
 

·
Registered
Joined
·
94 Posts
Discussion Starter #9
Well my heater blower exploded today
Does anyone know where I can get an old unit from so I can remove the blade and fit it to mine as I can't afford 50£ at the min
Cheers dan
 
1 - 9 of 9 Posts
Top