Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
clk 320
Joined
·
1 Posts
Discussion Starter #1
I am a recent BMW convert and bought my first "used" Mercedes about two months ago (99 CLK 320). Please respond if you have seen or experienced this..... My check engine light comes on all the time and my fuel gauge will sometimes show empty when it is not. I have even had a lamp defective light come on even though all of my lamps/lights/signals work.

Believe me, I know that a loose gas cap will cause the above mentioned. I keep it tight. Before I get ravaged by a dealer, I would appreciate any help someone can offer. Thanks.

[:(]
 

·
Registered
CLK320
Joined
·
3 Posts
The fuel gauge issue is a common problem and is well known to both dealerts and MB alike, ...

The fuel gauge issue is a common problem and is well known to both dealerts and MB alike, it will require replacement of the fuel sender(s) in the gas tank. Maybe you can get the dealer/MB to cut you a deal on getting it fixed.


Martin
 

·
Registered
'99 CLK 320 Cabriole
Joined
·
9 Posts
I just got my '99 CLK320 Cab back from the dealer. One fuel sending unit later, my fuel g...

I just got my '99 CLK320 Cab back from the dealer. One fuel sending unit later, my fuel gauge is working properly again.

Thankfully, the dealer knew of the problems these units were having and had it covered by MB despite the warranty having just expired 6 weeks before.


I hope you are as lucky as I was.
 

·
Registered
Joined
·
17 Posts
I have the exact same situation, with the exception of the gas tank problem, and the sam...

I have the exact same situation, with the exception of the gas tank problem, and the same car. Can you pls keep me posted on what happens. Trying to take it to the used car lot to have them fix it but they keep giving me the run around.
 

·
Registered
-06' CLS500 Lorinser-08'-MC Design Whips Project SL -06' Land Rover-
Joined
·
419 Posts
The same thing happened to me on both accounts with the fuel sender and the blown lights o...

The same thing happened to me on both accounts with the fuel sender and the blown lights on the dash.
 
1 - 5 of 5 Posts
Top