Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
1989 420sel
Joined
·
26 Posts
Discussion Starter · #1 ·
1989 420sel my left front brake has a strange feeling when coming to a final stop........its smooth pressing on the brake until the final stop 1mph then it feels like its grabbing metal. just had my upper and lower left ball joints replaced. and front shocks, 4 wheel balance and alighment...and i had the brakes inspected was told that the brakes were in new condiation...which i knew........never heard this sound until i replaced the left ball joints and shocks ...do anyone have any idea what this might be......
Thanx in Advance ........................James
 

·
Registered
380SE 1985 125000
Joined
·
111 Posts
Maybe the mechanic got some grease on the rotor. You might try to take the wheel off and spray it down with brake clean to see if this helps but sometimes the heat from braking burns the grease or oil into the pad and replacement is the only cure and be sure to have your rotors turned also since this might glaze that rotor also. Good luck
 

·
Registered
Joined
·
1,285 Posts
Hey, smallchange, have you ever seen the movie Small Change, by Francois Truffaut ? It is a subtitled French film. One of the best movies that I have ever seen.
 

·
Registered
1989 420sel
Joined
·
26 Posts
Discussion Starter · #6 ·
i took the car to the shop they removed the tire, caliper, cleaned the rotor, and pads checked the wheel bearing and it all looked good so he said that it must be the brake sensor........will post results in a few days...........smallchange225
 

·
Registered
380SE 1985 125000
Joined
·
111 Posts
I would be very careful now to make sure what your mechanic is telling you about the sensor is true. If the sensor he is talking about is the pad worn out sensor that tells you when your pads need replacing I don't understand how it could be making your brakes feel that way unless it fell out somehow and got jammed in between your pad and rotor.
 

·
Registered
380SE 1985 125000
Joined
·
111 Posts
Maybe I should not sound so harsh about your mechanic. I assumed that the car was also grabbing or pulling to the left but I see you did not mention that so I would give your mechanic a chance before you take my advise.
 

·
Registered
1989 420sel
Joined
·
26 Posts
Discussion Starter · #11 ·
under the hood on the right hand side is the ABS unit
the sensors cost $300 each i needed the left and right front sensors....plus labor from the Dealer...WOW...but now she stops smooth without the noise and and paulsing........
 

·
Registered
1989 420sel
Joined
·
26 Posts
Discussion Starter · #12 ·
http://www.mbnz.org/forums/forums/thread-view.asp?tid=1200080&posts=2&fid=12
check the link above it might help you locate it
 
1 - 12 of 12 Posts
Top