Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
Hi Everyone.

Just bought myself a 110 on an X plate with 147k miles.

I intend to do an awefull lot to the van over time, so I might be asking a fair few questions.
I have gone through and read loads and have created a document with most of the info I will need on, however, I have a few questions that I couldn't find answers for, hence this post.

Firstly, my gear change seems VERY stiff. I am assuming it shouldn't be like this, however I haven't driven any other Vitos to compare it to too. There was a thread on hear about greasing the cables but no instructions on how to do this. Can anyone help?

Secondly, if I have my interior light set to come on and go off when the doors open and close, whenever I go over a bump or even change gear, then the light keeps flickering. Is this a knackered door switch (or two), or can you adjust them?

Is there any photos/guides on how to remove interior stuff. Headliner for example. I have found one for removing the dash stereo surround and the one to get access to the pollen filter, but nothing for headliner and A pillar covers.

Is there an inspection hole or anything to be able to view the CAM belt? I am missing some service history so I don't know when the CAM belt was last done you see. I was hoping there would be a way to have a look and see what state the belt is in, rather than just biting the bullet and paying for a new one. The previous owner only had it for a year you see, so whilst he can confirm he never had it done, he can't vouch for the owner before him.

Thanks everyone and please accept my apologies if there are indeed answers to these questions and I simply haven't found them.

Paul
 

·
Registered
Vito 108cdi
Joined
·
305 Posts
There is no cambelt on the CDi engine, it's chain driven, so one less thing to go wrong :)

It could be the cables that need cleaning / greasing, or the selector mechanism on top of the gearbox, or the gearbox itself, there is info on here somewhere if you dig a bit deeper!

I would imagine the light is a faulty switch or wire, it should be easy enough to sort once you find which one is faulty, try wiggling them and see if that causes the same effect.

Good luck :thumbsup:
 

·
Registered
Joined
·
73 Posts
Discussion Starter #3
Hi there.

Thanks for the reply. I shall continue my search for how to lube the cables and how to remove the headliner.
Shame there isn't a "How Too" section where all these things can be stored and easily viewed.
Thanks for the info about the CAM chain also.

My first priority is this lot. I am assuming this is all quite normal for a van of this age etc?





















I don't have any photos of the front cross member but lets just say I will need a new one from a scrappy because mine is rusted so bad.

This is my first Mercedes and I must admit, I'm not impressed. I sold a 10 year old Ford Cougar and that had zero rust on the body panels and arches.

Looks like lots of sanding back to bare metal, treating and then filler and paint for me !!!!

Can anyone tell me the paint code btw please?

Cheers

Paul
 
1 - 3 of 3 Posts
Top