Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an 03 ML 350 w/30,000 miles. I just bought it and the pedal is sticking or rough.. Took it to the dealer and they supposedly repaired it.... well it is the same.. anyone had this problem?? If so what fixed it??? I am new here so help me out if you can.. thanks Ken
 

·
Registered
Joined
·
675 Posts
There are so many entries about this problem.... do a search.. I fixed mine by spraying lithium grease on the bolt that holds the pedal and lubed all the accessible areas of the linkage...
Are you getting the money back from the dealer for this "repair"??? just curious....
 

·
Premium Member
Joined
·
16,769 Posts
Practically every new member does not fully complete the registration form by including the year and model of their vehicle. Please click on USER CP to the left, then click on EDIT PROFILE, scroll down to ADDITIONAL INFORMATION and insert the year and model of your truck.

I could be one of two things or a combination of the two. The first illustration shows you what Wolfwinter was talking about and the second shows the continuation of the cable from the gas pedal. Inspect the full length of the cable for cracks. They usually show up at the point where the plastic ends and the metal rod starts.
 

Attachments

·
Registered
Joined
·
601 Posts
good luck. they replaced my cable, did nothing. i would have them replace the pedal assembly, but its not worth it, so i usually just go down there and grease all the pivots and springs. seems to help a little
 

·
Registered
Joined
·
24,029 Posts
I have an 03 ML 350 w/30,000 miles. I just bought it and the pedal is sticking or rough.. Took it to the dealer and they supposedly repaired it.... well it is the same.. anyone had this problem?? If so what fixed it??? I am new here so help me out if you can.. thanks Ken
If the dealer really repaired it, it is time to do those foot exercises.
 
1 - 6 of 6 Posts
Top