Mercedes-Benz Forum banner
1 - 11 of 11 Posts

· Registered
1984 Mercedes-Benz 300SD Turbo; 1985 300CD Turbo
Joined
·
163 Posts
Discussion Starter · #1 ·
Hey Gang,

So I posted this in the 126 section and was hoping I might get a little help over here.

So yesterday I began the task of installing a SONY XPOD stereo into my 1984 300SD. I consider myself, after 6 years of working on these cars, pretty competent; however, this handed my @ss to me. The stereo removal was a piece of cake, and I THOUGHT I had it installed correctly but when I tested it no sound out of the speakers; only static. And...when I drove it to work, I turned off the engine to find the head light buzzer was going off and my exterior lights would not turn. Subsequently, I had to disconnect the battery overnight.

To be honest, at this point I am at a loss and was wondering if anyone could help. Please note, I do NOT wish to bypass the center console fader; I don't have the time to open that can of worms.

From my knowledge (and PLEASE correct me if I'm wrong.
Mercedes wiring:
Brown = Ground
Black = Switch Ignition +
Red = Always on +
Grey = Dash lights (no idea where to connect this, however, to the new wiring harness.
Speaker Connection from old Becker unit
Red-Brown LT Front and Brown (originally connected to red-brown) = LT Rear
Gree-Black RT Front and Black (originally connected to green-black) =RT Rear

NEW wiring harness:
Black = Ground
Blue = Factory Labeled Antenna
Blue (again) = Power Amp (I left this disconnected)
Red = +12V power terminal/energized by ignition switch
Yellow = +12V energized at all times
White = + Front left
White/Black Stripe = (-) Front Left
Grey = + Right Front
Grey/Black Stripe = (-) Front Right
Green = + Left Rear
Green/Black Stripe = (-) Left Rear
Purple = + Right Rear
Purple/Black Stripe = (-) Right Rear

I couldn't even begin to tell you how many wiring configurations I used for the speakers. None worked.

Could someone PLEASE describe what connects to what. I'm dying over here and the old becker was shot, and I have searched the internet and all of forums with zero answers.

All the Best,
[email protected]
 

· Registered
1984 Mercedes-Benz 300SD Turbo; 1985 300CD Turbo
Joined
·
163 Posts
Discussion Starter · #3 ·
Okay,
So I got everything working in terms of sound and antenna. YES!
But...I still can't figure out what is going with dimmer/lights. I still have the headlight buzzer going off and the license plate is left on.

Any idea?
 

· Premium Member
W-1-2-3 Go!
Joined
·
16,164 Posts
I'm guessing your SD had an electronic stereo which is why it has the gray wire. The lights turn on and the radio LCD back light turns on to illuminate the display. Does the new stereo have a compatible corresponding wire? Some units have it so that if the lights are turned on, the stereo is "dimmed" so the light intensity is not too bright.

Does the buzzer/exterior lights have any problem with the gray wire disconnected? Where is it connected now?

Do you not have a wire from the car for the antenna switch? An '84 SD should still have the antenna switch. Was the radio you removed stock? Or was it aftermarket?
 

· Registered
1984 Mercedes-Benz 300SD Turbo; 1985 300CD Turbo
Joined
·
163 Posts
Discussion Starter · #5 · (Edited)
Okay so I conquered the '84 Mercedes-Benz 300SD aftermarket stereo install, and the image below describes, in detail, the wire configuration. Please note, that this is IF you choose to use the master fader in the center console. Otherwise, you'll need to clip the wires connected to the center console fader and wire them to the remaining Left and Right + and - Rear speakers.

This is for future users and I hope it helps. EVERYTHING...works perfect now in my car from this configuration.

Enjoy.
 

· Registered
Mercedes Benz 1981 240 D 4 Speed
Joined
·
200 Posts
Okay so I conquered the '84 Mercedes-Benz 300SD aftermarket stereo install, and the image below describes, in detail, the wire configuration. Please note, that this is IF you choose to use the master fader in the center console. Otherwise, you'll need to clip the wires connected to the center console fader and wire them to the remaining Left and Right + and - Rear speakers.

This is for future users and I hope it helps. EVERYTHING...works perfect now in my car from this configuration.

Enjoy.
http://i654.photobucket.com/albums/u...ps3156fb7f.jpg
Pics not showing :crybaby2:
 

· Premium Member
W-1-2-3 Go!
Joined
·
16,164 Posts
Okay so I conquered the '84 Mercedes-Benz 300SD aftermarket stereo install, and the image below describes, in detail, the wire configuration. Please note, that this is IF you choose to use the master fader in the center console. Otherwise, you'll need to clip the wires connected to the center console fader and wire them to the remaining Left and Right + and - Rear speakers.

This is for future users and I hope it helps. EVERYTHING...works perfect now in my car from this configuration.

Enjoy.
No more door buzzer or license plate lights turning on?

Okay,
So I got everything working in terms of sound and antenna. YES!
But...I still can't figure out what is going with dimmer/lights. I still have the headlight buzzer going off and the license plate is left on.

Any idea?
 

· Registered
1984 Mercedes-Benz 300SD Turbo; 1985 300CD Turbo
Joined
·
163 Posts
Discussion Starter · #9 ·
YUP! EVERYTHING is now working. I had the Grey (dash light) connected to the Red (+) always on and THAT is what was causing all the issues with the lights.
 

· Registered
1983 W123 300D Turbo Diesel
Joined
·
43 Posts
Hi I have black and red wire and green and black wire from the fader in the back of the radio. Where do they go? And where does the yellow wire from the radio go ( to which wire from the Mercedes? I do not know which wire is a constant 12v?
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top