Mercedes-Benz Forum banner

1 - 20 of 20 Posts

·
Premium Member
1999 S600 & 1999 S500
Joined
·
801 Posts
Discussion Starter #1
How many steering wheel tilts are still working, vs those that don't?

All three of my W140's tilt worked when I first purchased them. However, it eventually quit working. Fortunately they quit in the full down position. The in-out still works and did on the other two. I have read about the plastic dog-bone that breaks and causes the tilt to quit working. The return on investment, to repair, has always seemed to little for me to repair, especially since mine have all been daily drivers.
 

·
Premium Member
1999 S600 & 1999 S500
Joined
·
801 Posts
Discussion Starter #2
Please reply whether yours does or does not work. This is an unscientific survey. My bet is that most do not work.
 

·
Registered
W140 Mercedes 500 SE, 1992, European, 410.000 km
Joined
·
3,602 Posts
+1 for here. both functions work however "recall settings" button on the doors does not affect "up-and-down" function of the steering wheel so I must set it directly with the switch under the steering wheel.
 

·
Moderator
1995 Mercedes S420, 2000 Land Rover Discovery II, 1985 Lotus Turbo Esprit
Joined
·
1,642 Posts
Mine works fine, 168,000 miles. And I adjust the wheel constantly.
 

·
Premium Member
1999 S600 & 1999 S500
Joined
·
801 Posts
Discussion Starter #8
Well Damn! So much for my unscientific survey! However, my 3 out of the 6 others reported is still 50% do not work.

Why did all three of mine quit working? I can hear the motor, but no tilt. The memory will adjust the in-out, but not change the tilt.
 

·
Registered
1994 S600 Coupe, 1995 S600 Coupe
Joined
·
1,707 Posts
Your math is off. There's a total of 9 cars with your three included. So 3 ÷ 9= .3333 or 33% don't work.

Jon
 

·
Premium Member
1999 S600 & 1999 S500
Joined
·
801 Posts
Discussion Starter #10
This engineer can't add. It's like my first boss said, liars figure and figures lie. Jal, Thanks for correcting my math. Mine does sound worse. Still 33% seems high.
 

·
Registered
1995 W140 S280
Joined
·
41 Posts
The one on my S280 doesn't work. I'm trying to figure out how to fix it although it's in a rather comfy spot right now.
 

·
Premium Member
'97 CL600
Joined
·
2,842 Posts
I'm a little late but both of mine have worked from the git-go. My current '97 CL600 has 70K and my previous '97CL500 now has about 165K (and is listed for sale on this forum.)
Anziani
 

·
Registered
1994 S500 W140
Joined
·
14 Posts
I'm a little late but both of mine have worked from the git-go. My current '97 CL600 has 70K and my previous '97CL500 now has about 165K (and is listed for sale on this forum.)
Anziani
For the record my S500 No Workie🙁
 

·
Registered
94 - S500 Cpe
Joined
·
347 Posts
Please reply whether yours does or does not work. This is an unscientific survey. My bet is that most do not work.
My '94 S500 coupe . . 125K miles . . . still works and the memory settings recall its position. Sorry to be so late but just discovered the thread.
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,531 Posts
My ex S500 & 600SE booth work flawless ,the S500 i just swapped cluster on it an hour ago for Jimmy & it still works perfect . On my current 600SEL it only worked out & in but not up/down , A little tightening & re lubricating the motor underneath made it work flawless again ,this was last year ,still works up to now 100% .
 

·
Premium Member
1996 Mercedes Benz S500 sedan,1997 S500,2012 s550
Joined
·
54 Posts
I have a 96 S500 420,000 km and both functions still work.

I have a 97 S500 210,000km and both work and I have a 2012 S550 and both functions work.




Sent from my iPhone using Tapatalk
 

·
Premium Member
1999 S600 & 1999 S500
Joined
·
801 Posts
Discussion Starter #20
My ex S500 & 600SE booth work flawless ,the S500 i just swapped cluster on it an hour ago for Jimmy & it still works perfect . On my current 600SEL it only worked out & in but not up/down , A little tightening & re lubricating the motor underneath made it work flawless again ,this was last year ,still works up to now 100% .
Were you able to do this without pulling the steering wheel?
 
1 - 20 of 20 Posts
Top