Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
When I come out and start my 2000 ML55 AMG for the first time, and it’s cold, the car turns over strong but takes a longer time to catch. Sometimes it catches and chugs pretty hard, vibrates the whole vehicle, before it smooths out, the engine will rev up pretty good before idling back. I’ve read some threads on the fuel pump but this only seems to be first start on a cold day and doesn’t happen once the car has been driven a little. Seems to be tied to first start of the day and cold temp. Any thoughts??
Also, turn signals aren’t canceling. I assume that it’s the entire switch assembly on the column that needs to be changed.

thanks and Happy Thanksgiving to all!
 

·
Registered
w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Joined
·
1,743 Posts
No CEL mentioned. Scan for any saved codes perhaps.
Hard to diagnose as it could be many things (ie. cps, fuel, moisture.... just to name a few...)
Turn signal - maybe worn - replacement is the bes/ cheapest option from a pick n pull.
 

·
Registered
2003 C320 coupe, 2000 ML320
Joined
·
516 Posts
Have you considered an Aux. engine heater ?... Myself.. I don't like starting any engine below freezing without an Aux. heater on it overnight..
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
Have you considered an Aux. engine heater ?... Myself.. I don't like starting any engine below freezing without an Aux. heater on it overnight..
Well.....when I say cold I mean like below 40F, not sure if my cold is your cold, haha I dream of beach life living
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
No CEL mentioned. Scan for any saved codes perhaps.
Hard to diagnose as it could be many things (ie. cps, fuel, moisture.... just to name a few...)
Turn signal - maybe worn - replacement is the bes/ cheapest option from a pick n pull.
Just got it back from the dealership and they did AB inspection and replaced a couple of things, hard to believe it could have been showing codes and they didn't mention it. They gave me a list of "fix this" items but nothing was immediate. They did mention replacing the plugs,, could that be related to this issue? They didn't mention fuel filter or anything....

also, I had them fix an oil leak that they determined was from oil/coolant heat exchanger, guess what still leaking, so trying to decide whether to take back or find another MB mechanic, I hate leaking vehicles...
 

·
Registered
2003 C320 coupe, 2000 ML320
Joined
·
516 Posts
40F.. nah.. You shouldn't be having a problem with that.. Could be fuel?.. Also could be the CPS.. Normally CPS.. act up when they are hot.. but cold could effect it too.. If it's been scanned with "no codes".. Good luck.. It then turns into a hit and miss..
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
40F.. nah.. You shouldn't be having a problem with that.. Could be fuel?.. Also could be the CPS.. Normally CPS.. act up when they are hot.. but cold could effect it too.. If it's been scanned with "no codes".. Good luck.. It then turns into a hit and miss..
temperature...now thats a great question...what temp should this thing run at? Outside temp around 60F going down the highway and it runs somewhere between 80C-95C, maybe gains about 10deg if you're just sitting still and idling
 

·
Registered
2003 C320 coupe, 2000 ML320
Joined
·
516 Posts
Running down the highway, my 320 never see anything above 80C.. Stuck in traffic, 95C wouldn't be out of the question.. But for sure, you want to keep it under 100C.. Turn on AC or heater to being down temp if it starts tipping into the 100s..
 

·
Premium Member
2000 ML55 sold😢 2013 ML500,😁 2015 C250 estate wagon, 1927 Dodge 4 sedan, 1929 Dodge
Joined
·
4,607 Posts
I would start with a fuel filter and then your plugs.
 

·
Registered
Dallas, Texas
Joined
·
6,849 Posts
temperature...now thats a great question...what temp should this thing run at? Outside temp around 60F going down the highway and it runs somewhere between 80C-95C, maybe gains about 10deg if you're just sitting still and idling
Anything less then 105C is fine.
 

Attachments

1 - 12 of 12 Posts
Top