Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
mercedes 430
Joined
·
45 Posts
Discussion Starter · #1 ·
Hey guys hope u can help me? I parked my car for about 4 hours, came back and the car is out of battery, I jump the car and it started. I was driving home on the freeway and the car died. I had a friend bring me a new battery, installed the darn thing but it still wouldnt start. I tried to start It, it would click once and then nothing happen. I think it could be the starter, because it doesnt turn over. Please help????
 

·
Registered
Joined
·
497 Posts
It is still most likely to be the battery, was the new one charged?

I am having trouble with my battery which goes dead after a few days, I just jump it from my (much smaller) spare battery and it starts OK.


edit: Make sure the connections to the battery are clean and good.
 

·
Registered
02ML320 & 06RClass (sold)
Joined
·
1,632 Posts
slvr430ml - 4/10/2006 1:59 AM

Hey guys hope u can help me? I parked my car for about 4 hours, came back and the car is out of battery, I jump the car and it started. I was driving home on the freeway and the car died. I had a friend bring me a new battery, installed the darn thing but it still wouldnt start. I tried to start It, it would click once and then nothing happen. I think it could be the starter, because it doesnt turn over. Please help????
My question to you why you didnt call from your TeleAid - Roadside Assistance.
 

·
Registered
Black 2005 ML 500
Joined
·
1,662 Posts
I guess the MCS prompted you for the radio code and you entered it.. right..?

AC
 

·
Registered
98ML320
Joined
·
1,278 Posts
marcelc - 4/10/2006 6:26 AM

It is still most likely to be the battery, was the new one charged?

I am having trouble with my battery which goes dead after a few days, I just jump it from my (much smaller) spare battery and it starts OK.


edit: Make sure the connections to the battery are clean and good.

If you need to jump your battery every few days I'd suggest you run to the dealer and get a new battery because very soon, the jump won't do it either. Been there done that.
 

·
Registered
Joined
·
497 Posts
bigcatny - 4/10/2006 5:13 PM

marcelc - 4/10/2006 6:26 AM

It is still most likely to be the battery, was the new one charged?

I am having trouble with my battery which goes dead after a few days, I just jump it from my (much smaller) spare battery and it starts OK.

edit: Make sure the connections to the battery are clean and good.
If you need to jump your battery every few days I'd suggest you run to the dealer and get a new battery because very soon, the jump won't do it either. Been there done that.
Yes, I know, but I am being a cheapskate because in another month my ML will be 4 years old and one of the local Mercedes dealers gives 10% discount on parts if your vehicle is over 4 years old.

I did call out the 24hour response man when it first went dead and he checked it all and said that the battery was fine, he said there was a 270mA leak from the Command system and that I should leave fuse 21 out unless I went on long drives or replace the Command system.

I did some further testing and the 270mA drops to zero in 30 minutes and the leak current from the battery is less than 10mA (with the ML locked of course) after half an hour.

I will change the battery when I feel strong enough as it looks quite a lift to remove it.
 

·
Registered
mercedes 430
Joined
·
45 Posts
Discussion Starter · #7 ·
ok guys, found out that the new battery was not charged. Using jumper cable didnt help either, untill we brought out the battery jump starter. we got the car to start, tested the alternator by taking out the negative terminal and the car stoped. First indication of alternator problems, then brought out a volt meter and tested the alternator and it reading 9 volts, I think is the alternator, so we are changing it out, mb quoted $1250 for a new one(oooch) that kinda hurts, so we had to go with a rebuilt($250). Hope this works, ill keep you guys posted. thanks for the help guys
 
1 - 7 of 7 Posts
Top