Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1986 300E Sedan 160K
Joined
·
37 Posts
Discussion Starter #1
Here is my current conundrum on my 300E:
It has developed a starting issue - This happens more when it is cold, but will also happen when the engine is warm(ish). It never fires on the first crank (after about 15-20 seconds of cranking), it will however, start up on the second crank but will immediately die unless i give it fuel. The vacuum gauge will go into the red and the revs will drop till it dies. If I keep my foot lightly on the throttle and keep it at about 1000 rpm, after maybe a minute of that, the idle will normalize at 600 rpm and the car will stay on just fine and operates normally. Never had any issues with it stalling while under way or stalling while stopped in drive.

Here are all the things I have replaced so far, all with new parts:
Fuel Filter
Air Filter
Cap, plug, and rotor of the correct Bosch type (did not replace plug wires)
OVP relay
O2 sensor (Bosch generic type, had to wire into existing plug)
Lastly I took it to a indie mechanic here who adjusted the duty cycle that I had possibly messed up and replaced the water temp. sender.

Other than the starting issue, this thing is running great now. My economy and performance has improved since I first got it.

The one thing I noticed is that the wiring going to the cold start valve plug is rather poor, but I was under the impression that the cold start valve only operated under a certain ambient temperature and it was been plenty warm as of late.

Any other suggestions?
 

·
W124 Moderator
86 190E 2.3L 16V, 2 95 320TE's, 02 S500
Joined
·
12,760 Posts
Have you tried cycling the ignition key a few times before going all the way to the start position? Fuel filter changed?

Jayare
 

·
Registered
1987 300E, 1955 Plymouth Belvedere, 2005 Silverado 4x4
Joined
·
963 Posts
My car was slow to cold start I replaced the Cold Start Injector Plug and cleaned the terminals. fixed the problem. The replacement plug is available from AH and PP among other Bosch suppliers. It was under $20 IIRC.
 
1 - 3 of 3 Posts
Top