Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
142 Posts
Discussion Starter #1
The battery is plenty charged but when I go to turn the starter over nothing happens. I mean nothing. No clicks, ticks, grinding or other sounds. Nothing dims or anything. I've noticed nothing that would indicate a problem before this. Is there any troubleshooting I can do first that can rule out the starter? Thanks!

-Matt
 

·
Registered
Joined
·
1,939 Posts
If the NSS checks out take a rubber mallet and give the solenoid a good whack. If it works after that you have a sticky/failing solenoid. If nothing it's likely already failed. In general, check for loose wires and connections on the starter. Clean the contacts while you're at it.
 

·
Registered
Joined
·
5,001 Posts
On the Fender Well in front of your Battery you have a Wire Junction/Terminal Block.
Hook up a Remote Starter Switch to where the Arrows Point in the pic. If you Starter does not work when you jump those Terminals you have a Starter Problem.

Make sure the selector is in P or N. Cycle through all the gear positions and try Starting in in N. If it starts in Neutral it could be that your Neutral Safety Switch is going out and/or the Shifter Bushings need to be replaced.

I do not know if your cars wiring is the same but I got part of this quote from another Forum concerning a no cranking problem with an 84 300D.
Above the accelerator pedal is a 4-wire plug with a harness that runs down to under the accelerator pedal and to the transmission tunnel. Unplug it, jumper across the two purple wires in the female plug and try to start again. If it starts, you need a Neutral Safety Switch.

Of couse it is possible for the Ignition Switch itself to have a problem so you need to see if the Ignition Switch is sending the Voltage down to the Neutral safety switch.
 

Attachments

·
Registered
Joined
·
129 Posts
Well, at least you know your NSS works :)

I wish I was so lucky...about to go whack my solenoid with a hammer to see if that works. :mad:
 

·
Registered
Joined
·
16 Posts
Same Problem with 280ce M110

I have the same problem and I am trying to jump the starter. However I have a 280ce with M110 and a manual transmission. The relay that I have is displayed below. What 2 terminal do I need to jump to check if the starter will crank. Thx
Anees
 

Attachments

1 - 9 of 9 Posts
Top