Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1 (Edited)
I've been having started issues since I got my 240D about a month ago.

It would sometimes just spin without engaging. I opened it, cleaned and lubed everything. It's better now, but sometimes it advances just enough to make that horrible noise of a starter grinding against the ring gear. I really hate that noise, so I have to sort it out!

I my searched on the site and on the web I found that 240D's seem to have this starter with the three screws on the solenoid.
First one with the normal aluminium nose and the other is a replacement I can get here in South Africa with a cast iron nose.

http://www.benzworld.org/forums/attachment.php?attachmentid=414762&stc=1&d=1323596344

http://www.benzworld.org/forums/attachment.php?attachmentid=414763&stc=1&d=1323596344

My starter however looks like this one, with two hex bolts on the solenoid.
(This is not my actual starter, but it looks exactly like this one)

http://www.benzworld.org/forums/attachment.php?attachmentid=414764&stc=1&d=1323596344

http://www.benzworld.org/forums/attachment.php?attachmentid=414765&stc=1&d=1323596344

What's the story with my starter? Is it just a different make, or is it from the wrong vehicle?
 

Attachments

·
Registered
Joined
·
817 Posts
Only thing I found that the nose on some starters is longer. The '77 300D needed the shorter nose and I couldn't find one. Don't know about 240D
 

·
Registered
Joined
·
5,001 Posts
When I had a similar issue on another 2 vehicles it turned out the Ring Gear Teeth were burred to extent the it sometimes kept the Starter Gear from engaging the Teeth.

Filing the burrs off returned everything to normal.
I still own one of the Vehicles and it starts OK.
 

·
Registered
Joined
·
6,561 Posts
Google 9000693003 mercedes

and you only get South African hits...

...I'll dig out my starter motor and read off the numbers for you sometime this week...
 
1 - 7 of 7 Posts
Top