Mercedes-Benz Forum banner

21 - 32 of 32 Posts

·
Outstanding Contributor , SDS Guru
1998 MB E300TD, 1997 MB E36 AMG, 2001 MB E55 AMG
Joined
·
3,648 Posts
I bought one with code h226wk, I think that could be imported, its so high cost here.

Thinking about fuel, pressure, pump... the last owner adaptaded the fuel pump, and her mecanic make two hole on that squared on the top of fuel pump to pass the wired of pump (I don't understand why he make, but I don't have tool to open), and I think this could be losing pressure inside the tank, I put now some glue to close this hole, I will wait to try start again.

I'm angry, so many adaptations on this vehicle, but just 40k miles, I will make she back new again.

See what he done...
For sure I need change It.
View attachment 2620594
Yeeeeah that's not factory at all. See if you can get a original fuel pump and remove that blue wire, it seems that the previous mechanic put an aftermarket fuel pump in the fuel pump housing itself.

Can't you buy any cheap w163 fuel pump, even on eBay? Surely they must be able to ship to your country?
 

·
Premium Member
2000 ML55 sold? 2013 ML500,? 2015 C250 estate wagon, 1927 Dodge 4 sedan, 1929 Dodge
Joined
·
4,802 Posts
Sure you didn’t buy it of a terrorist. Don’t push any unfamiliar buttons located near the steering wheel. Lol
I would pull that out before doing any more and replace it with a new pump and filter. You’ll be chasing your tail with that setup.



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
11 Posts
Discussion Starter #23
I try start on this morning , and stay the same, on 3rd he start,

I think because the years could be the check Valve fuel, anybody have the partnumber? Could be hard to find it here in Brazil or so expansive price.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #24 (Edited)
I try to find a used pump to change some parts, but a newer importaded it's more cheap than a used. I will buy a tool to remove that pump and put the older original pump, but take some time to arrive.

Yeah my ignition it's don't use the turn key 3 position, stay on 2 position Key and push the bottom, wired on relay, I forget that can be a terrorist, thinking I have lucky that don't exploded yet

He is blinded original , and haved so many rastreator and location, block, panic, lock ... I put it off all the system, because something could be block the ignition, but uncesfully.
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,087 Posts
I try start on this morning , and stay the same, on 3rd he start,

I think because the years could be the check Valve fuel, anybody have the partnumber? Could be hard to find it here in Brazil or so expansive price.
You should not need the special tool a piece of wood or plastic (shaped like a metal chisel) that you can put on the outside ridges of the lock ring and tap with a hammer in a couple of places should release it. As a precaution no metal on metal tools that can cause a spark.

This may explain something. The correct pump is 163-470-35-94-80 it is list as discontinued on 2 benz dealer sites, with no replacement given.

You never stated what year yours is but for a M Class 1998-2002

If you can afford or find it this Delphi is a good choice, my benz dealer said they were the OEM supplier. But it cost 200.00$ US
more details on - Delphi® FG1162 - Fuel Pump Module Assembly

Delphi® FG1162

Other wise proceed with caution, but a member or 2 have said they had no issues with a cheaper ones purchased online. There are many aftermarket US suppliers that will ship international.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #26
Now I can't do It because the tank is full I think tha coul be lower petrol, but the ssme, when downer level I Will try with some wood..

Nice price of fuel pump, thanks, but the shippment os high, $124, probaly just next month I Will have some money to try buy a new pump, until I will put the older pump.

In some few hours I Will test with a new crankshaft, I hope that's work, eliminated some possibilities.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #28
I changed now the crankshaft, stay the same problem, Just could be power supply or check Valve fuel/fuel pump assembly...
 

·
Registered
Joined
·
11 Posts
Discussion Starter #29
Hey guys, I see now, when she id cold started ok 2nd 3rd tried, and when she is hot in 7rd tried
Any sugestion what can do to fix It.
 

·
Purple Moderator
99 ML430, 00 ML320, 05 E500 4matic Wagon
Joined
·
21,990 Posts
Earlier in the thread Matt asked about the crankshaft position sensor. The symptoms you just described point to that as the issue.
Please only use a genuine Bosch or MB sensor if you decide to replace it.
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,087 Posts
Earlier in the thread Matt asked about the crankshaft position sensor. The symptoms you just described point to that as the issue.
Please only use a genuine Bosch or MB sensor if you decide to replace it.
His other issue is his pump we are pretty sure it is not an ML pump.

But it could be both pump and crankshaft sensor.
 

·
Purple Moderator
99 ML430, 00 ML320, 05 E500 4matic Wagon
Joined
·
21,990 Posts
I did see that wiring nightmare, but then the not starting when hot also makes me wonder if we are looking the two issues?
 
21 - 32 of 32 Posts
Top