Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
2011 Mercedes E350 4matic Wagon
Joined
·
1,023 Posts
Discussion Starter #1
I had the whole malfunction deal with the battery drain. 3 weekends in a row i had to jump start the battery. Then read a a post about the seat modules. The last time i had to jump start the car, the SRS warnign came on. I unpluged the seat modules and the drain stoped. Now the SRS light comes on everytime you start the car and satys on throughout the drive.
Anyone knows where to start to look for this? I checked fuses and they seem to be fine.
Any info on this would help!
Thanks:surrender:
 

·
Registered
2002 honda civic (sold), 2009 Mercedes ML350
Joined
·
1,344 Posts
what connections under the seat did you disconnect? I ask because you have SRS connections under there.
 

·
Registered
2002 C230 Sport Coup and 2006 ML350
Joined
·
1,127 Posts
Yes, you need Star Diagnostic to reset.
Then hopefully it won't come back.
 

·
Registered
2003 C240
Joined
·
2 Posts
Same problem with my C240

After changing the battery in my car, the SRS light lit up and subsequently stayed on after that. I took it to the dealership to see what the problem was. Apparently there was nothing wrong with the SRS system, it just needed to be reseted.
 

·
Registered
C320
Joined
·
151 Posts
hi there

i had the same but it goes off sometime and sometime on !!!!!!! i have taken the car to dealer and said ur SRS senor !!!!! damage


do u think so !!!!!!??:rolleyes:
 

·
Registered
2011 Mercedes E350 4matic Wagon
Joined
·
1,023 Posts
Discussion Starter #7
SRS light

I unplugged the CAN connection under the seat( the one that is the longest and slimmest) It seemed only to disable the seats and steering wheel and not seat heaters.
What was approximate bill to reset the SRS system?
Thank you!

P.S. The SRS light is on constantly it doesnt go off.
 
1 - 7 of 7 Posts
Top