Mercedes-Benz Forum banner
1 - 9 of 9 Posts

·
Registered
2005 R230 SL500
Joined
·
23 Posts
Discussion Starter · #1 ·
I have the SRS light on the instrument display. Also has message SRS - Restraint system take to workshop and SOS - Phone. It never goes off.
I have checked and cleaned both seat connections.
I bought the MB Diagnostic Scanner tool and code reader, icarsoft i980. Its description included SRS code reading and resetting. It does not. When I queue up the airbag diagnose it displays "Fault in communication with vehicle ECU".
The tool works when I queue up other diagnoses (reading and resetting codes).

Has anyone else used this scanner and had similar results?

How else can I reset the SRS fault?
 

·
Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,291 Posts
I have the SRS light on the instrument display. Also has message SRS - Restraint system take to workshop and SOS - Phone. It never goes off.
I have checked and cleaned both seat connections.
I bought the MB Diagnostic Scanner tool and code reader, icarsoft i980. Its description included SRS code reading and resetting. It does not. When I queue up the airbag diagnose it displays "Fault in communication with vehicle ECU".
The tool works when I queue up other diagnoses (reading and resetting codes).

Has anyone else used this scanner and had similar results?

How else can I reset the SRS fault?
SRS codes stick, for safety reasons, even if the cause is repaired. Aftermarket scanner rarely work properly or fully to perform advanced reset tasks, or pull accurate codes.

Many aftetmarket scanners focus on being compatible with as many makes and models as possible, to appeal to widest customer base, instead of getting you accurate codes, therefore, you often see with these scanners generic code explanation, that tends to be close, but not quite what's needed to repair.

For all of these reasons, a Mercedes dedicated scanner, known as SDS, is the most accurate way to get this diagnosed (if needed) and erased.
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550 FORMER: C300, ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
24,974 Posts
iCarsoft i980 is an aftermarket scanner, but dedicated to MBZ. I don't have one myself (I use SDS), but I know many people who have the iCarsoft and have used to diagnose and reset SRS and other MBZ-proprietary system codes. Maybe there is something else going on with your car that prevents it from communicating with the SRS module?
 

·
Registered
r230 SL500
Joined
·
50 Posts
I too have an iCarsoft i980 and a 2005 SL500 and have addressed this same SRS malfunction notice on the instrument panel readout. I disconnected both seat (yellow housing) connectors and used a spray connector cleaner on the contacts. Once reconnected, I was able to use the i980 unit to clear the code. This warning has reappeared one other time and I repeated the cleaning process with the same result. This connection is quite sensitive and since it is located right at the front of the seats and just off the floor, it is very vulnerable to foot traffic and thus dust/dirt.

Do make certain to connect the unit before turning on the ignition and don't disconnect it until the ignition is turned back off.
 

·
Registered
2005 R230 SL500
Joined
·
23 Posts
Discussion Starter · #5 ·
Thanks so much for the information. Sorry for late response.
I will recheck seat connectors latter today and use some electrical contact cleaner.
I did contact the vendor that sold me the scanner and they were very supportive, tried hard to solve my problem.
I was thinking that maybe my SRS fuse had blown or the connector to the SRS ECU had disconnected? All fuses in the under hood fuse box are good. I have not found the SRS ECU yet.
 

·
Registered
2005 R230 SL500
Joined
·
23 Posts
Discussion Starter · #6 ·
I rechecked both seat connectors, cleaned and reconnected - no help. Tried again and used dielectric grease when reconnecting - no help. Removed dielectric grease, cleaned again, checked connector pins, reconnected - still not working?

Next: the dealer issued a fix with a kit to replace the yellow connectors, I will get a set from dealer this week and install - hopefully that will do it... Part number?

If not, then it will be a trip to dealer or independent to see if their Mercedes scanner can connect and reset the code?
 

·
Outstanding Contributor
2005 SL600, (2) 2003 SL500
Joined
·
4,588 Posts
Next: the dealer issued a fix with a kit to replace the yellow connectors...
This is documented in a bulletin M-B issued to its dealers in '02. I would think that by MY2005 the problematic connectors mentioned in that bulletin would have been phased out of production.

The part number for the kit is 230-540-58-05.
 

·
Registered
2005 R230 SL500
Joined
·
23 Posts
Discussion Starter · #8 ·
I originally posted this over a year ago. I still have the car and the red "SRS" light on the dash. Time has elapsed for several job changes, moving and family medical issues. I am back on the problem again, trying to get the car ready for sale.

Original problem on 2005 SL500:
I bought the MB Diagnostic Scanner tool and code reader, icarsoft i980. When I queue up the airbag diagnose it displays "Fault in communication with vehicle ECU". No codes displayed?

About 8 months ago I took it to an Indy in Albuquerque and the mechanic diagnosed the same thing, could not see any codes. They thought I might have a bad SRS module or lost power or ground to the SRS module. Suggested I take it to dealership. Also quoted me a price of $984 for the SRS module and that I would have to take it to the dealer to get coded.

Last week I purchased a used SRS module on the internet. The seller listed the vehicles vin number, and it looked to be close in production to my vin. After installing the used SRS module I still have the red SRS light on the dash. Tried turning the steering wheel left to lock and right to lock 5 times, SRS will not turn off. Drove the car for about 30 minutes, still would not turn off.
But, in the dash display for mileage, there is no reading that I have an SRS problem and/or SOS take it to the workshop?

I connected the code reader and queued up the airbag diagnose and it now recognizes that I have an SRS module! It displays "SRS module has a different vin number". Tried clearing the fault, responds with "all faults successfully cleared". But, the red SRS light is still on. Therefore, my SRS module was bad!

How can I get my vin programmed into the SRS module? Is it the dealer only who can do this?
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550 FORMER: C300, ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
24,974 Posts
iCarsfot won't do any coding. You'll need SDS (Star Diagnosis) for that.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top