Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
'10 Mbz S550, '03 Mbz C240, '03 Audi A4 2.0 Stroker, '08 Lexus SC430 PB Edition, '07 Prius
Joined
·
643 Posts
Discussion Starter · #1 ·
YESTERDAY I STARTED MY CAR AND THE SRS LIGHT STAYED ON AND THE MULTIFUNCTION DISPLAY SAID SRS MALFUNCTION DRIVE TO WORKSHOP AND IT'S NOT GOING AWAY. I'M TAKING IT TO THE DEALER TOMORROW. I'M UPSET BECAUSE IT IS MY FAVORITE CAR AND IT'S ONLY 8 MONTHS OLD AND IT SHOULDN'T HAVE THIS PROBLEM. ALL I EVR TALK ABOUT IS ABOUT HOW GREAT THE QUALITY OF MERCEDES-BENZ IS AND THIS KIND OF PUTS A DENT IN MY THOUGHTS.
 

·
Registered
'06 ML350
Joined
·
284 Posts
This is a common problem. There appears to be a loose connector for the airbag. It's already happened to me twice.

I can understand your frustration, but you have to remember this is the first rollout of this model. Yes, I know, they should have done a better job at it, but as I'm sure you'll agree, companies are under pressure to release their products on time and on budget. We are also in an age where cars include a very high number of electronic components. Making sure the probabilities of failure are minimal is a daunting task and as such, early adopters like you and me are going to have to "beta-test" the cars.

Having said all that, I'm very happy with my ML. I've had it over 9 months now and the problems I've had have been minimal. It's a great car and I still admire it every time I drive.
 

·
Registered
MBs
Joined
·
2,656 Posts
...and the TSB [;)]

Issued: Tue, Jan 17, 2006
TSB Number: T-91-60-93A
Title: Restraints - SRS Lamp ON and or DTC's 9200 and or 9210 Set
http://www.alldata.com/tsb/Mercedes-Benz/1137484800000_1139212800000_T-91-60-93A/index.html
 

·
Registered
'10 Mbz S550, '03 Mbz C240, '03 Audi A4 2.0 Stroker, '08 Lexus SC430 PB Edition, '07 Prius
Joined
·
643 Posts
Discussion Starter · #4 ·
You were right Dimitris, it was a loose connector, i took it to the dealer today and i should pick it up tomorrow. I was frusturated because i was driving back from Palm Springs to L.A. and i was worried about having an accident and the airbags not deploying, and my kids were in the car. I guess it was only a reflex. I still Love my truck. It's my second ML thats a new rollout. I still love it.[:D]
 

·
Registered
06 ML350
Joined
·
492 Posts
Villa,

if you do not have someone sitting in the passenger seat, that airbage will be off. You will see a little orange light on the command center towards the bottom. That is only for the passenger seat and is normal. If you have some other type os malfuntion, it would appear in your message section of your MFD on your dash. I hope this answers your SRS question and hopefully it is only the pasenger airbag and not something else.

Mike
 

·
Registered
GL 450
Joined
·
1 Posts
I am having the same problem. SRS malfunction front left.... I had it serviced 3 times and it keeps recurring. Did you get your problem resolved? Any special tricks to fix it? Manhattan Dealership is incompetent.
 
1 - 6 of 6 Posts
Top