Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi can someone help me out on this? there is a loud squeaky noise when i turn on the air-con but the noise disappear when turn off. this is really annoying. the noise seems to be coming from the drive belt area. could it be the compressor? i also notice the engine fan won't turn when i turn on the air-con. anyone experience this before? btw my ride is a 108D.
 

·
Registered
2000 108CDI, 2007 120 CDI long, Suzuki K5 GSXR track bike, 2005 Kawasaki ZX10R
Joined
·
1,423 Posts
Sonds like the compressor has siezed, pop the belt off and see if you can turn the compressor by hand with the belts removed and the aircon switched on.

Cheers Martin
 

·
Registered
V220 CDI 2003
Joined
·
848 Posts
collinwg said:
Hi can someone help me out on this? there is a loud squeaky noise when i turn on the air-con but the noise disappear when turn off. this is really annoying. the noise seems to be coming from the drive belt area. could it be the compressor? i also notice the engine fan won't turn when i turn on the air-con. anyone experience this before? btw my ride is a 108D.
It could be as simple as a 'loose' drive belt mate, check that belt is tight, or isn't worn out.


:)
 

·
Registered
Vito 280 ,ZX7r,gsxr 750, ,Z650 Cafe ,Benelli Tornado.Ford consul , Ford Pop , ,Chevy Astro,Dog,Wife
Joined
·
1,479 Posts
Agree..loose belt, dont know what that has to do with the fan though, its electric..
 

·
Registered
Joined
·
311 Posts
Your model Vito's aircon is powered by a 90 oz mouse, seems he is getting bolshy about being asked to work hard, hence the load squeeking, try chucking cheese in one of the vents....
 

·
Registered
108d big orange shaggin wagon v280 639 109
Joined
·
280 Posts
rufus said:
Your model Vito's aircon is powered by a 90 oz mouse, seems he is getting bolshy about being asked to work hard, hence the load squeeking, try chucking cheese in one of the vents....

pmsl i was going to say till i read urs rufus that ur hammster wheel needs oiling lol:D
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
thanks for all the replies...gonna check out the belt first...hope the compressor could hang in there.
 

·
Registered
Bandwidth
Joined
·
3,256 Posts
Don't think a loose belt would cause the 'squeak' as this was usually associated with the traditional v-belts (ford cortina, escorts and the like!), these modern 'serpentine' belts do not slip or can't slip as they are always under 'tension', thus the tensioners, etc. The squeak could be caused by the tensioner pulley on the way out or any other pulley eg: compressor, alternator, water pump(!) - best it as suggested by Walsi, remove the belt and turn all pulleys to pinpoint the problem.
 

·
Registered
Joined
·
311 Posts
on my 115 (2.2 CDI), the tensioner went peet tong, characterised by loud squeeling on start up for a few minutes, new belt and tensioner and sorted!

Do as the men say, check each pulley, just remember that the aircon has a magnetic clutch
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
Finally...cured the squeaky noise. it was the alternator tat has packed up. the batt warning light came on few days after. had installed a recon unit, now it sounds sweet and the air-con is working fine. the alternator model for 108D is a bosch 115amphere, my original unit lasted for 285000km.
 
1 - 10 of 10 Posts
Top